[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help with file copies

From: Ferguson, Steve
Subject: Help with file copies
Date: Tue, 8 Jul 2003 09:12:03 -0400

I'm trying to use the update.conf file on a node to force it to pull any
remaining conf files from a policy host.  I'm running cfengine-2.0.7p3.  My
primary problem is that no copy is actually happening.  I've boiled it down
to the simplest case I can.  I had no problem following the instructions to
manage the key exchange (and trust seems to be working) and have removed the
trustkey configuration options from the examples below.

The client system has this update.conf:


  actionsequence = ( copy )
  domain = ( )
  policyhost = ( )
  master_cfinput = ( /var/cfengine/master/inputs )
  workdir = ( /var/cfengine )


  $(master_cfinput)/cfagent.conf    dest=$(workdir)/inputs/cfagent.conf

I've also tried adding action=fix and force=true, to no avail.

The policy host (, for our purposes here) has this


  domain = ( )
  configs = ( /var/cfengine/master/inputs )
  AllowConnectionsFrom = ( xx.yy.zz )
  AllowMultipleConnectionsFrom = ( xx.yy.zz )
  AllowUsers = ( root )

xx.yy.zz is my actual IP range, removed for security reasons.

Running 'cfagent -v' on the client system produces the following output
(only the relevant parts are included; if you need more information, please

cfengine:: getservbynameChecking copy from
ter/inputs/cfagent.conf to /var/cfengine/inputs/cfagent.conf
Connect to = xx.yy.zz.228 on port cfengine
Loaded /var/cfengine/ppkeys/
cfengine:: Strong authentication of connection
cfengine:: Nothing scheduled for
var_cfengine_inputs_cfagent_conf (0/1 minutes elapsed)

I don't understand why nothing is scheduled.  There is no
/var/cfengine/inputs/cfagent.conf file on my client.  Why isn't it copying
/var/cfengine/master/inputs/cfagent.conf from the server?  I've tried
numerous permutations with the various force* options and action, in
addition to attempting recursive copies of all of
/var/cfengine/master/inputs to /var/cfengine/inputs.  In no case am I able
to get a single file to copy.

I've tried running both cfservd and cfagent with -d1, -d2, and -d3 flags.
None of them appears to produce any new information.

Any help would be most appreciated.  If I can get through this, I'll be
deploying to well over 100 servers and cfengine will become a key piece of
the infrastructure here.


Steve Ferguson
gedas USA, Inc.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]