help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cfexecd dies on startup, cfagent runs ok


From: Carl Hicks
Subject: Re: cfexecd dies on startup, cfagent runs ok
Date: 18 Nov 2003 17:43:17 -0800

Nevermind, I figured it out using cfexecd -gdv, it turns out that
/var/cfengine/bin is hardcoded into the source someplace.

-Charles

address@hidden (Carl Hicks) wrote in message news:<address@hidden>...
> I'm having a bit of a problem getting cfengine to behave properly,
> here's the problem:
> 
> Invoking cfagent through cfexecd returns the following message:
> cfexecd: cfengine defines no system administrator address
> cfexecd: Need: sysadm = ( address@hidden ) in control
> 
> I've verified that my configuration file contains the following
> information (I've replaced the real values with fake ones, just for
> this example):
> 
> control:
> 
>    AllowUsers     = ( root )
>    domain         = ( mydomain.com )
>    timezone       = ( CST )
>    smtpserver     = ( mail.mydomain.com )  # used by cfexecd
>    sysadm         = ( address@hidden )     # where to mail output
>    actionsequence = ( files shellcommands copy )
> 
> 
> Running a syntax check against the cfagent.conf file using cfagent -p
> returns no errors
> 
> Manually invoking cfagent --debug returns no errors, updates my
> checksums, etc.
> 
> Invoking cfagent -z produces the following output:
> 
> mail.mydomain.com
> address@hidden
> server.mydomain.com
> 192.168.0.100
> -1
> 
> Invoking strace cfexecd -F produces the following output:
> 
> open("/etc/hosts", O_RDONLY)            = 3
> fcntl64(3, F_GETFD)                     = 0
> fcntl64(3, F_SETFD, FD_CLOEXEC)         = 0
> fstat64(3, {st_mode=S_IFREG|0644, st_size=319, ...}) = 0
> mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
> 0) = 0x40014000
> read(3, "# Do not remove the following li"..., 4096) = 319
> close(3)                                = 0
> munmap(0x40014000, 4096)                = 0
> time(NULL)                              = 1069132714
> rt_sigaction(SIGINT, {0x400d3e90, [INT], SA_RESTART|0x4000000},
> {SIG_DFL}, 8) = 0
> rt_sigaction(SIGTERM, {0x400d3e90, [TERM], SA_RESTART|0x4000000},
> {SIG_DFL}, 8) = 0
> rt_sigaction(SIGHUP, {SIG_IGN}, {SIG_DFL}, 8) = 0
> rt_sigaction(SIGPIPE, {SIG_IGN}, {SIG_DFL}, 8) = 0
> umask(077)                              = 022
> pipe([3, 4])                            = 0
> fork()                                  = 17026
> close(4)                                = 0
> fcntl64(3, F_GETFL)                     = 0 (flags O_RDONLY)
> fstat64(3, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
> mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
> 0) = 0x40014000
> _llseek(3, 0, 0xbfffe610, SEEK_CUR)     = -1 ESPIPE (Illegal seek)
> read(3, "", 4096)                       = 0
> --- SIGCHLD (Child exited) ---
> 
> Any ideas?  Is it odd that cfagent -z is returning a -1?
> 
> Thanks,
> 
> -Charles


reply via email to

[Prev in Thread] Current Thread [Next in Thread]