help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with copy stanza not firing


From: Daniel Pittman
Subject: Re: problem with copy stanza not firing
Date: Fri, 05 Dec 2003 08:39:10 +1100
User-agent: Gnus/5.1003 (Gnus v5.10.3) XEmacs/21.5 (celeriac, linux)

On Thu, 4 Dec 2003, Luke A. Kanies wrote:
> On Mon, 24 Nov 2003, John S J Anderson wrote:
>> Daniel Pittman <address@hidden> writes:
>>
>> > Try adding the class to 'AddInstallable' in your control section. 
>> > That resolved a similar odd problem for me.
>>
>>   Thanks for the pointer, Daniel. When I reviewed the documentation
>>   for that option, I found this bit of information:
>>
>> Cfengine is not always able to see these classes until it meets them
>> and tries to save space by only loading actions for classes which is
>> believes will become defined at some point in the program. This can
>> lead to some actions being missed if the action is parsed before the
>> place where the class gets switched on, since cfengine is a one-pass
>> interpreter.
> 
> I just read someone's .sig which included the quote from Knuth about
> premature optimization, and I think this might qualify. This probably
> causes far more problems than it saves space.

I agree, but Mark does not. We had this argument when /I/ found the
ill-effects of it some while back. :)

            Daniel

-- 
Of the many unforeseen consequences of typography, the emergence of
nationalism is, perhaps, the most familiar.
        -- H. M. McLuhan, _Understanding Media: The Extensions of Man_, 1964




reply via email to

[Prev in Thread] Current Thread [Next in Thread]