help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: BerkeleyDB.4.2 Configure Error with 2.0.8p1 and 2.1.1


From: Armin Wolfermann
Subject: Re: BerkeleyDB.4.2 Configure Error with 2.0.8p1 and 2.1.1
Date: Thu, 29 Jan 2004 10:18:11 +0100
User-agent: Mutt/1.5.5i

* Brian E. Seppanen <address@hidden> [27.01.2004 19:44]:
> I just installed BerkeleyDB.4.2 on a host I'm trying to install cfengine 
> on and I get the following error when I run configure as follows
> 
> ./configure --with-berkeleydb=/usr/local/BerkeleyDB.4.2
> 
> 
> checking for BerkeleyDB location... /usr/local/BerkeleyDB.4.2
> checking Berkeley DB Version... configure: error: This release of cfengine 
> requires BerkeleyDB 3.2 or later
> 
> Does anyone know how I can get past this error?

The checks covered only versions 3.2 to 4.1. You can apply the attached
patch and regenerate the configure script.

--- configure.ac.orig   Thu Jan 29 10:01:23 2004
+++ configure.ac        Thu Jan 29 10:07:44 2004
@@ -154,14 +154,14 @@ else
     elif test -d "$BERKELEY_DB_DIR"; then
 
         BERKELEY_DB_CFLAGS="-I$BERKELEY_DB_DIR/include"
-        for v in . db41 db40 db4 db33 db32 db3 db; do
+        for v in . db43 db42 db41 db40 db4 db33 db32 db3 db; do
             if test -f "$BERKELEY_DB_DIR/include/$v/db.h"; then
                 BERKELEY_DB_CFLAGS="-I$BERKELEY_DB_DIR/include/$v"
             fi
         done
 
         BERKELEY_DB_LIB="-ldb"
-        for v in db41 db40 db4 db33 db32 db3 db; do
+        for v in db43 db42 db41 db40 db4 db33 db32 db3 db; do
             if test -f "$BERKELEY_DB_DIR/lib/lib$v.so"; then
                 BERKELEY_DB_LIB="-l$v"
             fi






reply via email to

[Prev in Thread] Current Thread [Next in Thread]