[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Partly fixed: Re: Still no e-mail reports

From: Luke A. Kanies
Subject: Re: Partly fixed: Re: Still no e-mail reports
Date: Thu, 5 Feb 2004 13:08:25 -0600 (CST)

On Thu, 5 Feb 2004, Tim Nelson wrote:

>       Well, I've gotten it to do test.example.local.  I changed the
> test.example.local in the /etc/hosts file to have a dot on the end, and
> then rebooted.  I'll have to put that in my cfengine config :).  It still
> doesn't send, but it's more sensible now :).

Is it not generating them, or are you not receiving them?  There's a very
large difference.

Check the local mail spools to verify that they are not actually being
generated.  You should probably also check your mail logs.

If they are being generated but not routed correctly to you, then you have
a problem with your mail routing, which I can help you with off-list if
you want.

If they are just not being generated at all, then i'm sure cfexecd is the
culprit.  I've apparently already deleted your original mail, so I don't
remember how much detail you provided.  I assume you're sure that cfexecd
is running successfully but just not generating any emails, right?
Cfexecd is a pretty simple program; all it does is 1) retrieve the
sysadmin email address from the cfengine configuration, 2) run cfagent
with no options (by default, anyway), and 3) email any cfagent output to

So, if 1) you've got the email address set up in the configuration, and 2)
cfexecd is able to run cfagent (it requires it to be in /var/cfengine/bin;
I make a link in update.conf), and 3) you can successfully mail from that
host, well, it should be working.  If you don't have those things, then
try them.

Good luck.


We either are networking, or we areNT networking...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]