help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Still having issues with multiple cfagents starting on clients


From: Mark . Burgess
Subject: Re: Still having issues with multiple cfagents starting on clients
Date: Fri, 15 Oct 2004 11:19:08 +0200 (MEST)

I recommend that everyone upgrades to the latest snapshot.
It seems stable and will likely be 2.1.11

M


On 15 Oct, Alexander Mattausch wrote:
> Chris Kacoroski wrote:
> 
>> Hi,
>>
>> I am still getting several clients getting started (e.g.
>>
>> [10-171-246-144:~] root# ps ax | grep cf
>>   431  ??  Ss     0:00.00 /usr/local/sbin/cfservd
>>   438  ??  Ss     0:43.63 /usr/sbin/ntpd -c /etc/ntp.cf -p 
>> /var/run/ntpd.pid
>>   445  ??  Ss     2:06.81 /usr/local/sbin/cfenvd
>> 14336  ??  Ss     0:00.02 /usr/local/sbin/cfexecd -F
>> 14377  ??  S      0:00.08 /var/cfengine/bin/cfagent
>> 15091  ??  Ss     0:00.03 /usr/local/sbin/cfexecd -F
>> 15155  ??  S      0:00.12 /var/cfengine/bin/cfagent
> 
> 
> Are there also defunct ifconfigs? If yes, then this mail from Mark will 
> help:
> 
>>I had a moment of inspiration and discovered that the pipe
>>that reads ipv6 addresses from ifconfig was incorrectly
>>terminated at line 483 in src/nameinfo.c with 
>>fclose() rather than pclose().
>>
>>I strongly suspect this is the reason for the zombies.
>>Current snapshot patches this, or you can fix manually.
>>
>>  
>>
> Regards,
> Alex
> 
> 
> 
> _______________________________________________
> Help-cfengine mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/help-cfengine



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Work: +47 22453272            Email:  address@hidden
Fax : +47 22453205            WWW  :  http://www.iu.hio.no/~mark
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~





reply via email to

[Prev in Thread] Current Thread [Next in Thread]