[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with cfservd on Mandrake 10.0 -- Solved.

From: Eric Sorenson
Subject: Re: Problem with cfservd on Mandrake 10.0 -- Solved.
Date: Thu, 21 Oct 2004 13:53:44 -0700 (PDT)

On Thu, 21 Oct 2004, Brian Thomas wrote:

> solved the problem entirely. I don't know why it's choking with db4,
> unless, that is, it's not supposed to work with 4? I dunno. 

Hi Brian, it's probably not so much that it doesnt work with 4, as
that it doesnt work with a different version than that which it was
compiled against. So you probably picked up the db4 libs and includes
from the autoconf tests but at runtime, finds the
before and h0rks.

In general the berkeley db stuff is really problematic for cfengine. 
Nany linux distros helpfully provide several versions (I've seen compat-db,
db3, *and* db4 on one box!) and our autoconf code for picking the right one
often doesn't.  Several "works for me" remedies have been proposed but
none has been proven to be the magic bullet.. & ff. & ff.


This best fix for this problem might just be writing up the various fixes
in INSTALL. Or just making sure the right answer percolates to the top
in google :-)


 - Eric Sorenson - Explosive Networking - -

reply via email to

[Prev in Thread] Current Thread [Next in Thread]