help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with cfservd on Mandrake 10.0 -- Solved.


From: Mark Burgess
Subject: Re: Problem with cfservd on Mandrake 10.0 -- Solved.
Date: Fri, 22 Oct 2004 08:30:44 +0200
User-agent: Mutt/1.4.2i

The problem here is that, in some linux dists, the header files of
one dist get picked up with the libraries of another. They are
not compatible. This is a problem with Berkeley db -- there are
to many different ideas about where to put it and what to call it!!
M

On Thu, Oct 21, 2004 at 10:43:34AM -0700, Brian Thomas wrote:
> So for the edification of folks here, I was having problems with cfservd
> dumping core under pretty much any load at all on a Mandrake 10.0 box,
> and did a little bit of debugging. It turns out it was freaking out
> after calls to libdb4.1, so I recompiled with this change.
> 
> Change:
> 
> BERKELEY_DB_LIB = -ldb
> 
> to
> 
> BERKELEY_DB_LIB = -ldb-3.3
> 
> In src/Makefile to force it to use the db3 libraries instead of 4. (You
> could of course also relink /usr/lib/libdb.so to the version 3.3 library
> instead of 4.1, but I didn't know what else that might break.) This
> solved the problem entirely. I don't know why it's choking with db4,
> unless, that is, it's not supposed to work with 4? I dunno. 
> 
> Brian
> 
> 
> _______________________________________________
> Help-cfengine mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/help-cfengine

-- 


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Work: +47 22453272            Email:  address@hidden
Fax : +47 22453205            WWW  :  http://www.iu.hio.no/~mark
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~





reply via email to

[Prev in Thread] Current Thread [Next in Thread]