help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem w/ copying files


From: Mark . Burgess
Subject: Re: problem w/ copying files
Date: Fri, 29 Oct 2004 21:45:19 +0200 (MEST)

Try type=checksum or type=binary (see manual)
M

On 29 Oct, address@hidden wrote:
> OK that is fixed - Is there a specific directive when copying files to say 
> that if the copy on the client has changed to get a new one from the 
> server? This is what Im using and it doesnt work - it only works if I 
> change the master file on the server.
> 
> copy:
>     linux::
>          /usr/local/cfengine/files/linux/resolv.conf
>                  dest=/etc/resolv.conf
>                  server=pcbackup
>                  mode=644
>                  owner=root
>                  group=root
>                  verify=true
> 
> All in all cfengine is turning out to be a huge time saver for me...
> 
> Thanks
> Ted Fiedler
> 
> On Fri, 29 Oct 2004 address@hidden wrote:
> 
>>
>>
>>
>> You are trying to copy a file that does not exist to itself!
>> Similarly, you have a typo in the other rule
>>
>> "cfegine" -> "cfengine"
>>
>> M
>>
>> On 29 Oct, address@hidden wrote:
>>> I changed things a bit to:
>>>
>>> copy:
>>>     linux::
>>>          $(masterfiles)/files/all/resolv.conf
>>>                  dest=/etc/resolv.conf
>>>                  mode=644
>>>                  owner=root
>>>                  group=root
>>>     linux::
>>>          /tmp/123
>>>                  dest=/tmp/123
>>>
>>> and when I run cfagent --verbose --no-splay on the client Im getting this
>>> and still no files are being copied to the client.
>>>
>>> *********************************************************************
>>>   Main Tree Sched: copy pass 1 @ Fri Oct 29 10:21:43 2004
>>> *********************************************************************
>>>
>>> Checking copy from
>>> localhost:/var/cfegine/masterfiles/files/all/resolv.conf to
>>> /etc/resolv.conf
>>> cfengine:unixbu1.uic.com: Can't stat
>>> /var/cfegine/masterfiles/files/all/resolv.conf in copy
>>> Checking copy from localhost:/tmp/123 to /tmp/123
>>> cfengine:unixbu1.uic.com: Can't stat /tmp/123 in copy
>>> Saving the setuid log in /var/cfengine/cfagent.unixbu1.uic.com.log
>>>
>>> *********************************************************************
>>>   Main Tree Sched: files pass 1 @ Fri Oct 29 10:21:43 2004
>>> *********************************************************************
>>>
>>>
>>> Thanks
>>>
>>> Ted Fiedler
>>>
>>> On Fri, 29 Oct 2004 address@hidden wrote:
>>>
>>>>
>>>>
>>>>
>>>> You don't say what happens/doesn't happen.
>>>>
>>>> M
>>>>
>>>> On 29 Oct, address@hidden wrote:
>>>>> Im rather new at this and have had luck with all classes execpt with copy:
>>>>> im running cf engine 2.1.11a4 the server is a slackware box and clients
>>>>> are redhat
>>>>>
>>>>> here are the lines Im haveing issues w/
>>>>> filestocopy     = ( /usr/local/cfengine/files )
>>>>>          scriptstorun    = ( /usr/local/cfengine/scripts )
>>>>>
>>>>> copy:
>>>>>     linux::
>>>>>          $(filestocopy)/all/resolv.conf  dest=/etc/resolv.conf
>>>>>                                          type=checksum
>>>>>                                          verify=true
>>>>>                                          owner=root
>>>>>                                          group=root
>>>>>                                          mode=644
>>>>>
>>>>>
>>>>>
>>>>> and when I run cfagent -d2 | tee cfagent.out here are the relevant lines I
>>>>> get.
>>>>>
>>>>> COPY /usr/local/cfengine/files/all/resolv.conf
>>>>>   Mode +644
>>>>>       -7133
>>>>>   TO dest: /etc/resolv.conf
>>>>>   action: fix
>>>>>   Size > -1
>>>>>   IfElapsed=1, ExpireAfter=120
>>>>>   recurse=0
>>>>>   xdev = n
>>>>>   uids = ( 0 )
>>>>>   gids = ( 0 )
>>>>>   filters:
>>>>>   exclude:
>>>>>   ignore:
>>>>>   symlink:
>>>>>   include:
>>>>>   classes = linux
>>>>>   method = c (time/checksum)
>>>>>   server = localhost (encrypt=n,verified=y)
>>>>>   accept the server's public key on trust? n
>>>>>   purging = n
>>>>>   Define
>>>>>   ElseDefine
>>>>>   FailoverClasses
>>>>>   Single backup archive
>>>>>
>>>>> Im not quite sure what Im doing wrong here. Any pointers would be greatly
>>>>> appreciated.
>>>>>
>>>>> Ted Fiedler
>>>>> _______________________________________________
>>>>> Help-cfengine mailing list
>>>>> address@hidden
>>>>> http://lists.gnu.org/mailman/listinfo/help-cfengine
>>>>
>>>>
>>>>
>>>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>>> Work: +47 22453272            Email:  address@hidden
>>>> Fax : +47 22453205            WWW  :  http://www.iu.hio.no/~mark
>>>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>>>
>>>>
>>>>
>>>>
>>> _______________________________________________
>>> Help-cfengine mailing list
>>> address@hidden
>>> http://lists.gnu.org/mailman/listinfo/help-cfengine
>>
>>
>>
>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>> Work: +47 22453272            Email:  address@hidden
>> Fax : +47 22453205            WWW  :  http://www.iu.hio.no/~mark
>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>
>>
>>
>>
> _______________________________________________
> Help-cfengine mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/help-cfengine



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Work: +47 22453272            Email:  address@hidden
Fax : +47 22453205            WWW  :  http://www.iu.hio.no/~mark
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~





reply via email to

[Prev in Thread] Current Thread [Next in Thread]