help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SOLVED: Disable deletes the file [again]


From: dp
Subject: Re: SOLVED: Disable deletes the file [again]
Date: Thu, 20 Jan 2005 13:06:03 -0800
User-agent: Mozilla Thunderbird 0.9 (Macintosh/20041103)

Harry Hoffman wrote:
Hi Eric,

Thanks very much for the help... I'm sorry to report (well, sorry that I was being stupid) that it was a typo that was catching me out...

Even though cfagent reported that it was moving the file to /etc/hosts.equiv.testing it seems to have taken precedence for
the value of the Repository (/var/spool/cfengine).

Unfortunately, I had a typo specifying that a tidy should take place in /var/spool/cfengine for everything older then age=0 (it should have been age=10).

The files were getting deleted before I ever saw them in the Repository.

Should the Repository setting override a dest in disable?


Thanks again,
Harry

Yes. As I recall you can add repository=false in the definition of each of the disabled files to prevent them from being moved to the repository.

dp


reply via email to

[Prev in Thread] Current Thread [Next in Thread]