[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cfexecd's still not terminating - 2.1.13/RH AS 2.1

From: David E. Nelson
Subject: Re: cfexecd's still not terminating - 2.1.13/RH AS 2.1
Date: Fri, 11 Feb 2005 13:49:23 -0600 (CST)

Hi Eric,

I performed another run and it ran for several hours only this time w/o a segfault. I also had 'strace' attached to the PID to get a better idea of what was going on at the system level. Oddly, the original cfexecd died (no segfault) and two other cfexecd's were still lingering around.

Since it appears that something in my env is causing this, would it help if I collected the 'gdb' output and forwarded it on? If so, I'll need some simple 'gdb' instructions on what you like to collect.


On Thu, 10 Feb 2005, Eric Sorenson wrote:

Hi David, thanks for collecting all this telemetry. This looks like
it might be locking badness, at least in part:

cfexecd: cfexecd: Couldn't get exec lock -- exists or too soon: IfElapsed 5, 
ExpireAfter 10
Unable to delete lock []: DB_NOTFOUND: No matching
key/data pair found
Unable to delete lock []: Invalid argument
Segmentation fault

I don't normally use cfexecd in daemon mode, so I'm running one
now under gdb to see if I can repeat this, but my config has kicked
off several times from the Schedule and it's OK so far.

~~ ** ~~  If you didn't learn anything when you broke it the 1st ~~ ** ~~
                        time, then break it again.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]