help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

defined classes in cfagent.conf not present from cfrun


From: Greg Retkowski
Subject: defined classes in cfagent.conf not present from cfrun
Date: Wed, 16 Feb 2005 12:28:21 -0800
User-agent: Mozilla Thunderbird 1.0 (Windows/20041206)

I've got a weird problem with cfengine, and I'm curious if anyone else
has encountered it, or if it's a 'feature' and if so how I work around
it. I define lots of classes/groups in my cfagent.conf file, mostly
based on if a file exists, and then various actions occur based on if a
system is in a given class. For example, if the system is a webserver
then there's a section in 'processes:' that'll restart a dead webserver
(and so on). This works fine running cfagent locally on the command
line, but when run remotely via cfrun none of the classes/groups I
define in cfagent.conf are defined when cfagent remotely runs.

So I've got in my cfagent.conf something like:

groups:
        is_webserver = ( "/usr/bin/test -f /etc/httpd/conf/httpd.conf" )

when  i run cfagent on the command line (with arguments -v --no-splay )
on the local host I get:

Defined Classes = ( ... is_webserver ... )
But if I run it remotely with 'cfrun somehost -- -v' the is_webserver
does not show up in Defined Classes.

This is on cfengine version 2.1.11.

Any clue??

-- Greg

-- 
Greg Retkowski /     I.T. Infrastructure Consultant      | RAGE
address@hidden  http://www.rage.net/~greg/ C:408-455-3913 | .NET





reply via email to

[Prev in Thread] Current Thread [Next in Thread]