[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cfagent segfaults during kickstart on FC4

From: Jeff Sheltren
Subject: Re: cfagent segfaults during kickstart on FC4
Date: Sat, 20 Aug 2005 14:12:35 -0700

On Aug 17, 2005, at 5:35 PM, Jeremy Dreese wrote:

On Wed, 17 Aug 2005, Klaus wrote:

I've merged in cfengine 2.1.14-fc4 into my Fedora Core 4 installation
tree, and call it during the '%post' phase of installation.

I've noticed that with prior versions (2.1.13 for sure, on EL4), things ran smooth as could be, but on FC4, cfagent segfaults or hangs. Anyone
else encountered this yet? Anyone have a good suggestion about how I
can track down the cause of the problem? During normal system runtime,
it works beautifully - it's just during installation that the problem

I had pretty much the same issue with 2.1.14 (on RedHat Enterprise Linux 3 & 4); the first time I called cfagent it segfaulted but subsequent runs on the same system worked fine. I wasn't doing the first run during a kickstart, but I experienced the same issue none- the-less. I never took the time to look into what exactly was going wrong, but just today I tried 2.1.15 and didn't have the same problem. You might try integrating 2.1.15 into your FC4 installation tree (if possible) and see if you have the same problem.


Indeed this was fixed in 2.1.15. We experienced the segfault using 2.1.14 both under kickstart and normal runs. It would only happen the first time cfagent was run on a system. As of 2.1.15 I have not seen this problem. I guess it is related to the changelog entry:
 Segmentatin fault in cfservd with RSA key exchange fixed.
but I'm not entirely sure about that.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]