help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: copy happening despite my rules.


From: Adams, Russell L.
Subject: Re: copy happening despite my rules.
Date: Fri, 30 Sep 2005 09:14:31 -0500
User-agent: Mutt/1.4.2.1i

Could it be a problem with the length of the hostname? What classes
does cfagent -v show being defined initially?

Russell

On Fri, Sep 30, 2005 at 09:30:16AM -0400, David Cress wrote:
> Some more info.
> 
> The machine I'm having problems on is damworker4ref3.  After changing
> cf.copy to:
>   copy:
>     !damworker4ref3::
>       /master/copy/samba/dam/smb.conf
>         dest=/opt/samba/lib/smb.conf
>         owner=root group=other mode=644
>         type=checksum inform=true
>         verify=true server=$(filehost)
> 
> I re-ran cfagent on damworker4ref3, it still tries to install
> /opt/samba/lib/smb.conf
> 
>    [BEGIN InstallPending File Imaging:
> IsInstallable(!damworker4ref3) - true
> 
> This makes no sense.  I've stated, I want /opt/samba/lib/smb.conf
> installed on any machine but, damworker4ref3.  When I run it on
> samworker4ref3, it gets installed.  Argh!!!  I've tried to make the
> statements as simple as possible, but it still does not do what I want.
>  Somehow I telling it to do the wrong thing and I just do not see it.
> 
> I even did an 'od' of cf.copy to see if there were any non-printing
> characters in there.  Nothing.
> 
> 
> David Cress wrote:
> > Here is the relevant part of my config for cfengine v2.1.15:
> > 
> > cf.groups:
> >   damworkerref = ( damworker4ref1 damworker4ref2 damworker4ref3 )
> > 
> > cf.copy:
> >   damworkerref.!damworker4ref3::
> >      /master/copy/samba/dam/smb.conf
> >         dest=/opt/samba/lib/smb.conf
> >         owner=root group=other mode=644
> >         type=checksum inform=true
> >         verify=true server=$(filehost)
> > 
> > 
> > When I run this config on damworker4ref3, (cfagent -d1 -q -n) I get the
> > following:
> > 
> > NEW CLASS PREDICATE:: damworkerref.!damworker4ref3::
> >    (No actions pending in File Imaging:)
> > InitializeAction()
> > HandleClass(damworkerref.!damworker4ref3)
> >    (No actions pending in File Imaging:)
> > Compound class = (damworkerref.!damworker4ref3) with 2 members
> > VAROBJ /master/copy/samba/dam/smb.conf
> > IsVarString(/master/copy/samba/dam/smb.conf) - syntax verify
> > Found 0 variables in (/master/copy/samba/dam/smb.conf)
> > Handling Object = (/master/copy/samba/dam/smb.conf)
> > 
> > 
> > It's reading everything in OK.
> > 
> > 
> >    [BEGIN InstallPending File Imaging:
> > IsInstallable(damworkerref.!damworker4ref3) - true
> > InstallImageItem (/master/copy/samba/dam/smb.conf) (+644)(-7133)
> > (/opt/samba/lib/smb.conf), server=sunman.turner.com
> > ExpandVarstring(/master/copy/samba/dam/smb.conf)
> > ExpandVarstring(sunman.turner.com)
> > SplitStringAsItemList(sunman.turner.com,:)
> > Build2DListFromVarstring(/master/copy/samba/dam/smb.conf,sep=/)
> > SplitVarstring(/master/copy/samba/dam/smb.conf,:=58)
> > IsVarString(/master/copy/samba/dam/smb.conf) - syntax verify
> > Found 0 variables in (/master/copy/samba/dam/smb.conf)
> > AppendTwoDimItem(itemlist, sep=/)
> > Set2DLIst()
> > Get2DListEnt()
> > Get2DLIstEnt returns /master/copy/samba/dam/smb.conf
> > IncrementTwoDimList()
> > 
> > 
> > This should be false, not true.  Why is the "!", not functioning?
> > 
> > On another box called 'sunman', it sees that it's not part of the
> > damworkerref class, and drops out just fine.
> > 
> > 
> >    [BEGIN InstallPending File Imaging:
> > IsInstallable(damworkerref.!damworker4ref3) - false
> > Not installing copy item, no match
> > (/master/copy/samba/dam/smb.conf,damworkerref.!damworker4ref3)
> > InitializeAction()
> >    END InstallPending]
> > 
> > 
> > I've got to be missing something something basic, and I just can not see it.
> > 
> 
> -- 
> David Cress
> Lead Engineer
> CNN Internet Technologies
> http://www.cnn.com
> --------------------
> (404) 878-1921
> 
> What exists, exists; what is, is.
> 
> 
> _______________________________________________
> Help-cfengine mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/help-cfengine




reply via email to

[Prev in Thread] Current Thread [Next in Thread]