[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Odd flag cut

From: paguerlais
Subject: Odd flag cut
Date: Mon, 28 Nov 2005 11:00:30 +0100

Hi all,

I'm in the process of upgrading all my clients from 2.0.7p3 to 2.1.17. But
before that upgrade, I'm conducting some tests to ensure everything is ok,
and I've found a strange behaviour.
I've encapsulated the use of cfengine in a Perl application, which
generates some cfrun commands. The call of cfrun is done with parameters
(in a -Dxxx way), so as to inform the client of what has to be done.
Nothing fantastic in that use of cfengine.
What becomes strange is that when the flag is exactly 'cfengine_conf', the
last 'f' is lost between cfrun and cfservd. I tried a lot of other strings
to figure out what's going on. The conclusion is that any string which ends
with an 'f' looses this last character. Any other last character I tried
(g, h, ...) has been kept...

For example :
/usr/local/cfengine/sbin/cfrun -f /tmp/cfrun.hosts.16229 -T -v -- -v -Daf
<----------------- the final 'f' is present
cfrun(0):         .......... [ Hailing <client_ip> ] ..........
Connecting to server <client_ip> to port 0 with options  -v -Daf
<----------------- the final 'f' is still present

(Non privileged user...)

Loaded /home/patrice/.cfengine/ppkeys/root-<client_ip>.pub
Connect to <client_ip> = <client_ip> on port cfengine

(Non privileged user...)

Loaded /home/patrice/.cfengine/ppkeys/root-<client_ip>.pub Strong authentication of
server=<client_ip> connection confirmed
<client_ip> replies..

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- -

cfservd Executing /usr/local/cfengine/sbin/cfagent --no-splay --inform -v
-Da   <---------------- the final 'f' has been lost

The problem seems to me more probably located in cfservd than in cfrun,
because of the line 'cfservd Executing...' which is the first to show the
truncated flag, but I'm not definitely sure.
Does anybody ever heard of cf truncating the final 'f' in a flag ? I'm
going to dig into cfengine sources, but any information can help me to
explain faster that strange behaviour.
Last thing : I didn't try any other cfengine version between 2.0.7p3 and
2.1.17, so I don't know if that problem appeared in a previous version or
if it is specific to that last one.

Thanks for your help
L'acces immediat aux meilleurs tarifs Air France et au billet electronique
For immediate access to the best Air France fares and to electronic
tickets, visit our website

Les donnees et renseignements contenus dans ce message sont personnels,
confidentiels et secrets. Ce message est adresse a l'individu ou l'entite
dont les coordonnees figurent ci-dessus. Si vous n'etes pas le bon
destinataire, nous vous demandons de ne pas lire, copier, utiliser ou
divulguer cette communication. Nous vous prions de notifier cette erreur a
l'expediteur et d'effacer immediatement cette communication de votre
The information contained in this message is privileged, confidential, and
protected from disclosure. This message is intended for the individual or
entity adressed herein. If you are not the intended recipient, please do
not read, copy, use or disclose this communication to others; also please
notify the sender by replying to this message, and then delete it from your

reply via email to

[Prev in Thread] Current Thread [Next in Thread]