[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

defaultroute problem with multiple network interfaces

From: Steve Sizemore
Subject: defaultroute problem with multiple network interfaces
Date: Fri, 6 Jan 2006 13:13:44 -0800
User-agent: Mutt/1.5.11

We have four subnets to be managed by cfengine. Following the examples
in the documentation, my cf.main contains






and this works fine for hosts with a single NIC.

A few of our servers, however, are connected to multiple subnets,
and therefore belong to more than one of these classes - e.g.
128_32_183 and 169_229_58. On those hosts, cfagent fails -

    cf:cfengine::/var/cfengine/inputs/cf.main:134: Multiple declaration of 
variable defaultroute
    cfengine::/var/cfengine/inputs/cf.main:Redefinition of basic system variable

which makes sense, more or less. (Except that it happens even when
netconfig is not in the actionsequence.)

To fix this, I tried the following,



However, this gives exactly the same error message.

Assigning the default route is not that important to me, but this
failure suggests a lack in my understanding of cfengine. In
particular, the fact that this happens even when netconfig is not in
the actionsequence list, is disturbing.

Can anyone help me understand what's happening and maybe fix it?
(BTW, this is cfengine-2.1.17, and the host I'm testing on is running
FreeBSD 6.0.)

Steve Sizemore <steve (at)>, (510) 642-8570
Unix System Manager
    Dept. of Mathematics and College of Letters and Science
    University of California, Berkeley

reply via email to

[Prev in Thread] Current Thread [Next in Thread]