help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cfagent on my policy host problem, pt 2


From: PAUL WILLIAMSON
Subject: Re: Cfagent on my policy host problem, pt 2
Date: Thu, 19 Jan 2006 16:21:46 -0500

>>> "Joe Buehler" <address@hidden> 01/19/06 11:26 AM >>>
> PAUL WILLIAMSON wrote:
> 
> > from the command line - I had to add /usr/local/ssl/lib to 
> > my LD_LIBRARY_PATH in my profile and it works fine now.
> > It still doesn't work from cron.  Does cron use a different 
> > profile to 
> 
> cron doesn't read your profile -- Try this in the crontab:
> 
> LD_LIBRARY_PATH=/usr/local/ssl/lib cfexecd
> -- 
> Joe Buehler

Great, now I'm slightly more confused.  In my master cfagent.conf 
file, I thought I'd try to push out the crontab modification via 
cfagent.  Strangely enough, it made the modification (added the 
LD_LIBRARY_PATH) to crontab, but I'm still getting the e-mail.

I've waited 2 cycles (one to modify, the next to actually utilize the 
new crontab entry), and I'm still getting the error.  Obviously cfexecd

is doing something, otherwise the crontab would not have been 
modified.

So it would seem the libcrypto message in my mailbox is not 
reflecting what is really going on...

Paul



_______________________________________________
Help-cfengine mailing list
address@hidden 
http://lists.gnu.org/mailman/listinfo/help-cfengine 






reply via email to

[Prev in Thread] Current Thread [Next in Thread]