help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: change in disks behavior between 2.1.18 and 2.1.19


From: Mark Burgess
Subject: Re: change in disks behavior between 2.1.18 and 2.1.19
Date: Fri, 03 Mar 2006 18:56:25 +0100

Please upgrade to 2.1.19p1 - this is an unfortunate bug

On Wed, 2006-03-01 at 17:20 -0800, Stephen Fromm wrote:
> I noticed a change in cfengine's behavior when checking the free space
> on partitions.
> 
> Here's a basic config I'm testing with:
> 
> ---BEGIN---
> 
> control:
> 
>     actionsequence = ( disks )
> 
> disks:
> 
>     /bin freespace=20% define=root_full
>     /usr/bin freespace=80% define=usr_full
>     /var/lib freespace=80% define=var_full
> 
> alerts:
> 
>     root_full::
>         "/ on $(host) is approaching full"
> 
>     usr_full::
>         "/usr on $(host) is approaching full"
> 
>     var_full::
>         "/var on $(host) is approaching full"
> 
> ---END---
> 
> When run with cfengine-2.1.18, I get the warnings (as expected) for /usr
> and /var.  When run on cfengine-2.1.19, I get the following:
> 
> ---BEGIN---
> 
> *********************************************************************
>  Main Tree Sched: disks pass 1 @ Wed Mar  1 17:14:33 2006
> *********************************************************************
> 
> cfengine:limbo: Couldn't stat disks checking diskspace
> cfengine:limbo: Free space above -20, defining
>  didn't find any file to match the required filesystem /bin
> cfengine:limbo: Couldn't stat disks checking diskspace
> cfengine:limbo: Free space above -80, defining
>  didn't find any file to match the required filesystem /usr/bin
> cfengine:limbo: Couldn't stat disks checking diskspace
> cfengine:limbo: Free space above -80, defining
>  didn't find any file to match the required filesystem /var/lib
> cfengine:limbo: MESSAGE at Wed Mar  1 17:14:33 2006
> 
> 
> cfengine:limbo: There are 3 required file(system)s missing on host <global>
> cfengine:limbo: even after all mounts have been attempted.
> cfengine:limbo: This may be caused by a failure to mount a network filesystem 
> (check exports)
> cfengine:limbo: or because no valid server was specified in the program 
> cf.test
> 
> ---END---
> 
> Please let me know if additional debug output is needed.
> 
> .sf
> 
> 
> 
> _______________________________________________
> Help-cfengine mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/help-cfengine





reply via email to

[Prev in Thread] Current Thread [Next in Thread]