help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: cfservd/cfenvd


From: Nielsen, Steve
Subject: RE: cfservd/cfenvd
Date: Tue, 7 Mar 2006 14:41:22 -0500

You do plenty right.  I really appreciate all the hard work that has
been put into cfengine.

Thanks!
Steve

-----Original Message-----
From: address@hidden
[mailto:address@hidden On Behalf
Of Mark Burgess
Sent: Saturday, March 04, 2006 2:10 PM
To: Erich Weiler
Cc: address@hidden
Subject: Re: cfservd/cfenvd


Please upgrade to 2.1.19p1 this is a bug
M

On Sat, 2006-03-04 at 09:17 -0800, Erich Weiler wrote:
> Hi Ya'll,
> 
> I've been beating my head over this for a long time and have no idea 
> what's going on, I was hoping one of you could shed some light on it:
> 
> I compiled cfengine version 2.1.19 on Solaris 9, no problems, compiled

> like a champ.  cfagent seems to work with no problems.
> 
> However, when I try to run cfservd or cfenvd, they die on me:
> 
> % ./cfservd
> cfservd: Cfagent aborted on defined class
> 
> I have config files set up and everything but it doesn't even get to 
> that point.  I tried it with the config files in the path, then 
> wiothout, hoping it would tell me my config file was messed up but I 
> don't think it's even trying to read config files yet.  I tried this
then:
> 
> % ./cfservd --debug
> 
> cfservd: Debug mode: running in foreground
> AddClassToHeap(any)
> AddClassToHeap(cfengine_2_1_19)
> Appending [cfengine_2_1_19]
> AddClassToHeap(cfengine_2_1)
> Appending [cfengine_2_1]
> AddClassToHeap(cfengine_2)
> Appending [cfengine_2]
> GetNameInfo()
> WildMatch(-,sunos)
> WildMatch(-,sunos)
> WildMatch(sunos,sunos)
> WildMatch(*,sun4u)
> WildMatch(4*,5.9)
> WildMatch(ultrix,sunos)
> WildMatch(hp-ux,sunos)
> WildMatch(aix,sunos)
> WildMatch(linux,sunos)
> WildMatch(sunos,sunos)
> WildMatch(sun4*,sun4u)
> WildMatch(5*,5.9)
> AddClassToHeap(solaris)
> Appending [solaris]
> AddClassToHeap(icicle)
> Appending [icicle]
> AddClassToHeap(icicle)
> Domain rejected
> AddClassToHeap()
> cfservd: Cfagent aborted on defined class
> 
> icicle is the name of the host.  I think the problem has something to
do 
> with the "Domain rejected" line there, but I can't find anything on 
> google about it, no one else seems to have the same problem.  Domain 
> entries in the config files are correct, but again I'm not convinced 
> it's even parsing the config files.  cfenvd does exactly the same
thing 
> when I try to run it.
> 
> Any ideas or clues?  Also, cfkey works fine, keys were made.  I'm
lost.
> 
> Thanks in advance for any insight!
> 
> ciao, erich
> 
> 
> 
> _______________________________________________
> Help-cfengine mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/help-cfengine



_______________________________________________
Help-cfengine mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/help-cfengine




reply via email to

[Prev in Thread] Current Thread [Next in Thread]