[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: eshell command substitution?

From: Stephen Berman
Subject: Re: eshell command substitution?
Date: Sat, 23 Dec 2023 17:46:48 +0100
User-agent: Gnus/5.13 (Gnus v5.13)

On Sat, 23 Dec 2023 11:30:05 -0500 Jeff Clough <> wrote:

> Jeff Clough <> writes:
>> Stephen Berman <> writes:
>>> This should work (see (info "(eshell) Dollars Expansion")):
>>> $ g++ base.cpp -o base ${pkg-config gtkmm-3.0 --cflags --libs}
>>> Steve Berman
>> Progress! Running that command, I get the proper output from pkg-config,
>> but it's wrapped in single quotes, which the compiler doesn't like.
> Wait, no. No, it's not. It's outputting exactly as it should.
> If I do this in gnome-terminal, it works...
> $ g++ -g -o base base.cpp `pkg-config gtkmm-3.0 --cflags --libs}`
> I can run the call to pkg-config by itself, and I get the endless line
> of options I expect.
> If I run this in eshell, it doesn't work...
> $ g++ -g -o base base.cpp ${pkg-config gtkmm-3.0 --cflags --libs}
> I get "g++: error: unrecognized command-line option '...'"
> With the enless line of options in quotes, but that's just the compiler
> quoting at me.

I get that with when the pkg-config command is wrapped in backticks, but
with ${} the compilation succeeds for me.

> If I do...
> ${pkg-config gtkmm-3.0 --cflags --libs}
> In eshell, I get the same result as if I ran pkg-config in
> gnome-terminal.
> I'm even more confused.


Steve Berman

reply via email to

[Prev in Thread] Current Thread [Next in Thread]