[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: arm-none-eabi-objdump: Reading section .bss failed because: memory e

From: Bob Proulx
Subject: Re: arm-none-eabi-objdump: Reading section .bss failed because: memory exhausted
Date: Mon, 6 Apr 2020 18:41:13 -0600

This mailing list has very little activity.  I don't know and would
normally comment but I hate to see people post questions and then not
get any response at all.  Therefore I will comment here in the hope
that I might be able to get you to a better place to ask your question.

Arjan van Vught wrote:
> What does the error mean? Is it just that the .list file is not
> generated completely?  This error got introduced when upgrading from
> version 7 to 9.

Upgrading what from version 7 to what version 9?  What is being

> arm-none-eabi-objdump -D lib_h3/libh3.a  | arm-none-eabi-c++filt > 
> lib_h3/lib.list
> arm-none-eabi-objdump: error: lib_h3/libh3.a(h3_codec.o)(.bss) section size 
> (0x800c bytes) is larger than file size (0xde8 bytes)

The BSS section is normally used to store static data.  In a C program
if one is defining a variable with initialized data then this will go
into the BSS section.

  int iii = 42;

It makes no sense if the BSS segment is larger than the file size.  It
makes me thing there is a data corruption problem.  Or perhaps the
file system is full and part of the file could not be written.  Or
potentially other problem of which this is only a down stream cascade
failure with a different root cause.


> arm-none-eabi-objdump: Reading section .bss failed because: memory exhausted

Memory exhausted indicates that the program tried to allocate memory
or tried to fork and whichever action it was failed due to being out
of virtual memory.

I would look to see if the storage filled up.  I would look to see if
whatever you are doing ran out of memory.

Since this is ARM I assume some type of NAND flash file system.  In
which case I would look for a failure of the storage such as due to
worn out storage cells.  If it is an SD card I would try reading from
every byte and verifying that the storage device is working okay.  I
have had SD cards using NAND storage and other similar devices fail
creating file corruption.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]