[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Koha-devel] strange problem with passing $dbh value

From: Stephen Hedges
Subject: [Koha-devel] strange problem with passing $dbh value
Date: Tue Apr 6 10:57:04 2004
User-agent: DreamHost Webmail

I need a clue...

I'm having a problem with import of bulk MARC records.  We just moved all
the Nelsonville Library Koha stuff to a new machine on Sunday, where we
are now using the new 2.0 release.  (Our old production machine had a
pasted together collection of Koha stuff, some of it 7 months old.)  In
the process we also moved our MARC import script.

Now something weird is happening.  When I try to run the script as any
user other than root, it fails because the bulkmarcimport call to the
&MARCfind_marc_from_kohafield function in Biblio.pm is not passing the
$dbh value.  So Biblio.pm throws a 'no database' error:

DBD::mysql::st execute failed: No Database Selected at
/usr/local/koha/intranet/modules//C4/Biblio.pm line 258.
(same error happens later in the script at Biblio.pm line 858)

If I "su" to superuser and try running the script again, it works.  (On
our old machine, it worked either way.)

The script is getting the value of $dbh from Context.pm without any
problem.  It just doesn't seem to pass the value to Biblio.pm unless the
script is run by the superuser.  All the Koha module permissions look OK
(755) -- although that shouldn't even be a factor.

I don't think this is a bug, I think I'm just overlooking something.  Does
anybody have any suggestions?

Stephen Hedges
Skemotah Solutions, USA
www.skemotah.com  --  address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]