[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Koha-devel] UTF-8 and Koha

From: Stephen Hedges
Subject: Re: [Koha-devel] UTF-8 and Koha
Date: Wed Jun 23 12:47:32 2004
User-agent: DreamHost Webmail

Thanks, Benedykt, but actually I discovered my problem was just my own
stupidity.  I found that I was searching for ISBN numbers that actually
were _not_ in the Library of Congress.  (I tried 4 different ones, what
are the chances that none would be in LOC?)  When I tried the ISBN search
again with an ISBN that I _knew_ was in LOC, then it worked like a charm,
didn't matter whether I was using the 2.0.0 code or your code.  I'm using
RedHat Enterprise Linux AS version 3, maybe there's something different
about your Fedora Code 1?


Benedykt P. Barszcz said:
> Stephen Hedges wrote:
> [...]
>> I'm working on installing Koha 2.0.0 on RedHat Enterprise Linux (and
documenting the process), and I'm running into utf-8 problems. [...]
> Gottcha!
> At last one more person stumpled upon it...!
> Read this:
>   /koha/z3950/encodingfix/README-english
> IMPORTING FROM Z39.50 SERVER WITH Character Set: win1250 (ISO 6937/2)
into KOHA-2.0 WITH UTF-8
> Files from this directory are here as a fix only and are of temporary
nature. The fix was delivered to me by Zbigniew Bomart.It will probably
work for the Polish Language only. The issue needs to be addressed by
Koha developers for the general audience.
> There's a general problem with z39.50 import feature for koha
> instalations whose default charset IS NOT iso-8859-1.
> When importing from z39.50 servers that keep their records in
> windows-1250 charset encoding and koha installation with UTF-8
> one may use the replacement files in this directory.
> Copy them to the following location:
> /usr/local/koha/intranet/modules/C4/Biblio.pm
> /usr/local/koha/intranet/cgi-bin/z3950/search.pl
> and enjoy importing records in UTF-8 from Character Set: win1250 (ISO
6937/2) servers.
> I tested it and the files seem to work on Fedora Core 1 and Koha-2.0
> Remember to set the appropriate permissions on the files once you copy
them. On my machine it is:
> -rwxr-xr-x    1 apache   apache      91813 May  2 18:34 Biblio.pm
-rwxr-xr-x    1 apache   apache       3263 May  2 18:39 search.pl
> Benedict P. Barszcz

Stephen Hedges
Skemotah Solutions, USA
www.skemotah.com  --  address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]