[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Koha-devel] Status of head (some infos)

From: Frédéric
Subject: Re: [Koha-devel] Status of head (some infos)
Date: Sat, 23 Jun 2007 19:58:31 +0200
User-agent: IceDove (X11/20070329)

>> 1- the librarian part of the install is now done through the
>> webinstaller
>> 2- the config file has heavily changed (.conf => .xml)
>> Does anyone plan to work on that in the next 2 months ?
> I think MJ has talked about re-doing this, but I'm not sure about
> the timeline ... MJ?

I would also be pleased to write this script. I'd need a functional
description of what it has to do.

>> Database commit
>> ================
>> A fresh install from the CVS won't work at all, i'm almost sure.
>> I'll commit a uptodate koha.sql and updated UNIMARC frameworks asap.
>> I'll let libLime or anyone else work on MARC21.
> Something for this Koha Project day I think ...

FYI, I've done an installation from CVS, doing at the beginning by hand
what a futur misc/install3.pl will do:

    * cvs checkout
    * koha.xml creation
    * empty koha_v3 db creation
    * I run a browser and I am redirected to /installer/install.pl
    * installation process blocks at step 3 with an error message:

    Koha › Web Installer › Step 3

    The following error occcurred while importing the database structure:
    Unknown suffix '-' used for variable 'port' (value '-u')
    mysql: Error while setting value '-u' to 'port'
    Please contact your system administrator

    * In install.pl, I've seen that koha db structure can't be loaded.
      So I create tables with /installer/kohastructure.sql.
    * I run koha in a browser and go to the next step: 
          o install basic configuration settings, or,
          o upgrading from a previous version of Koha.
    * I import frameworks (unimarc). Everything seems ok, except:

        * authorites_norme_unimarc.sql ERROR 1216 (23000) at line 680:
          Cannot add or update a child row: a foreign key constraint fails
        * Unimarc templates may not be complete, as explained Paul.

    * Installation is blocked at step 3 on frameworks loading. It seems
      that installer is expecting Version systemepreference variable to
      be set to 3.0 value.
    * I do it by hand: INSERT INTO systempreferences (variable, value)
      VALUES ('Version', '3')
    * Koha 3 is installed.
    * Some tweaking:
          o template variable is at 'default'. template='prog' and Koha
            is in French
          o intranetstylesheet=/intranet-tmpl/prog/en/includes/intranet2.css
            to have Koha 3 new style sheet.

Best regards,

-- Frédéric

reply via email to

[Prev in Thread] Current Thread [Next in Thread]