[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libunwind-devel] Urgent - Help - 64 bit google profiler crashes (li

From: Rajesh Balamohan
Subject: Re: [Libunwind-devel] Urgent - Help - 64 bit google profiler crashes (libunwind)
Date: Tue, 27 Feb 2007 05:40:48 +0530

Hi Arun,

The profiler unit tests works fine.

When I tried to profile one of our multi threaded applications, the following happens.

1. When we stop the program, it generates almost 26 Mb of google profiler data. (This is over a period of time)
2. When we try "pprof --gv --lines /opt/tms/bin/mxed /tmp/mxed_profiler_4" , it shows the GV and with only sample. And concentrates only on main thread.

We are compiling everything with -g option. Not sure why it is not able to retrieve the data in the 26Mb.


On 2/27/07, Arun Sharma <address@hidden> wrote:
[ + google-perftools ]

On 2/26/07, Rajesh Balamohan <address@hidden> wrote:
> PROFILE: interrupts/evictions/bytes = 10307/4141/657160
> The output of the profiler is saved as follows
> ==================================.
> ls -lrt /tmp/mxed_profiler_3
>  -rw-r--r--  1 admin root 666921 Feb 26 13:02 /tmp/mxed_profiler_3
> When I run,
> pprof --gv --lines --nodecount=200 --nodefraction=0.0005 /opt/tms/bin/mxed
> /tmp/ mxed_profiler_3
> I get only couple of nodes and the number of samples says "8". So it means,
> may be only 8 samples were taken during the run of over 3 or 4 minutes?

[ From your posting to google-perftools ]

> address@hidden google-perftools-0.8]# pprof --text /localdisk/google-
> perftools-0.8/profiler1_unittest /tmp/test.3
> WARNING: program /localdisk/google-perftools-0.8/profiler1_unittest is
> apparently not an ELF file

I didn't see any indication that libunwind is at fault here. Probably
the issue is that pprof is not able to find the correct ELF binary to
map addresses to symbols.

Could you try:


assuming that's where libtool put the actual ELF binary?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]