[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libunwind-devel] config.h inclusion in libunwind-x86_64.h

From: Lassi Tuura
Subject: Re: [Libunwind-devel] config.h inclusion in libunwind-x86_64.h
Date: Mon, 5 Sep 2011 17:31:03 +0200


>  as I've said in my previous mail, I was installing libunwind 1.0 in a
> linux-x86/64 machine. I found that my installed libunwind-x86_64.h
> references in line #35 a config.h which does not exist in my
> $prefix/include. In fact, it does it my tool configure fail, but that's
> another story.
>  I've checked against libunwind-0.99 and #include "config.h" was not
> there, so I just commented out line #35 of  libunwind-x86_64.h and it
> worked like a charm.
>  Is this a known issue? Is it safe to proceed this way?

Yes, we had the same issue on RHEL5. In the RPM we build, I added

  cp include/config.h %i/include

Here %i is the install prefix. I think it's not a good idea to omit it,
as various defines will act as if they didn't exist then.

This was after adding the 'autoreconf' I mentioned in my other message.
I did check this with Arun before the release, and he mentioned the build
worked on Ubuntu for him, so there must be some sort of autotools glitch
here - and not one I've understood yet.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]