[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users]Enabling ALSA drivers?

From: Matthew Lawson
Subject: [Linphone-users]Enabling ALSA drivers?
Date: Fri, 06 Jun 2003 13:37:15 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1


I am attempting to use Linphone to call a Cisco 7960 phone over Asterisk. I am using Debian Linux 3.0r1 (Woody?). I am using the ALSA intel8x0 sound driver.

What happens, audio from the computer to the Cisco is OK, but audio from the Cisco from the computer doesn't arrive until 4 MINUTES later. That's right, minutes not seconds. I'm using Linphone 0.11.0. I'm also using the command-line only version (linphonec). The user's manual says to select "use ALSA" from the Gnome GUI, which I obviously can't do, and I can't figure out if there's a flag in the .linphonec configuration file that should be set for this.

I tried using the --enable-alsa switch with configure, and the "-DALSA" flag seems to be set, but when I run the program, it appears to still be using the OSS routines. I put diagnostic messages in the "alsa_read/write" and "oss read/write" routines and it's still using the oss routines. Is this right?

If not, how do I get it to use ALSA, and is this likely the problem?


- Matt

reply via email to

[Prev in Thread] Current Thread [Next in Thread]