[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] Relocations in generic ELF (EM: 3)

From: Prakash N
Subject: [Linphone-users] Relocations in generic ELF (EM: 3)
Date: Tue, 25 Apr 2006 14:33:00 +0100 (BST)

I'm trying to cross-compile linphone in powerPC platform. I followed the README.arm and replaced with power-pc cross compile tools. While I do make in libosip2.2, I get an error like this,
/opt/powerpc-405-linux/lib/gcc/powerpc-405-linux-gnu/3.4.1/../../../../powerpc-405-linux-gnu/bin/ld: .libs/osip_md5c.o: Relocations in generic ELF (EM: 3)
.libs/osip_md5c.o: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[3]: *** [] Error 1
make[3]: Leaving directory `/home/prakash/ppc/linphone/libosip2-2.2.2/src/osipparser2'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/prakash/ppc/linphone/libosip2-2.2.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/prakash/ppc/linphone/libosip2-2.2.2'
make: *** [all] Error 2
I searched web and could find same problem, in arm platform.
I tried the suggestion of configuring by giving
CC=powerpc-405-linux-gnu-gcc AR=powerpc-405-linux-gnu-ar RANLIB=powerpc-405-linux-gnu-ranlib NM=powerpc-405-linux-gnu-nm LD=powerpc-405-linux-gnu-ld STRIP=powerpc-405-linux-gnu-strip CXX=powerpc-405-linux-gnu-g++ CFLAGS=-O2 ./configure --disable-trace --disable-debug --host=powerpc-405-linux --with-gnu-ld --disable-static  --disable-buffermode --prefix=/usr
and make.
But still I get same error,
Could anyone explain how to get rid of this error,

Jiyo cricket on Yahoo! India cricket
Yahoo! Messenger Mobile Stay in touch with your buddies all the time.
reply via email to

[Prev in Thread] Current Thread [Next in Thread]