[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] Can Linphone use iLBC?

From: Clement Chen
Subject: Re: [Linphone-users] Can Linphone use iLBC?
Date: Thu, 10 Apr 2008 09:49:11 +0800

Hi, Stephen,
    Sorry for replying this mail late due to my loaded work recently..^^;;
Finally, I figured it out that patching msilbc-2.0.0/Makefile is the best way
to solve this library linking problem. Here is an example:
0. I used "./configure --prefix=/usr/local" to compile "ilbc-rfc3951"
  * Then I used "/usr/local/lib" and "/usr/local/include" for following steps.
1. Add two variables "PLUGIN_CFLAGS" and "PLUGIN_LIBS" in msilbc-2.0.0/Makefile :
----------Makefile BEGIN-----------



  PLUGIN_LIBS="-L/usr/local/lib -ldl -lm -lilbc" \
  PLUGIN_CFLAGS="-I/usr/local/include" \
  PLUGIN_NAME=msilbc \

  PLUGIN_LIBS="-L/usr/local/lib -ldl -lm -lilbc" \
  PLUGIN_CFLAGS="-I/usr/local/include" \
  PLUGIN_NAME=msilbc \
  PLUGIN_SOURCES="ilbc.c Makefile README ilbc-rfc3951.tar.gz" dist

  PLUGIN_LIBS="-L/usr/local/lib -ldl -lm -lilbc" \
  PLUGIN_CFLAGS="-I/usr/local/include" \
  PLUGIN_NAME=msilbc \

  PLUGIN_LIBS="-L/usr/local/lib -ldl -lm -lilbc" \
  PLUGIN_CFLAGS="-I/usr/local/include" \
----------Makefile END-----------

2. Compile msilbc-2.0.0 and install

3. Start linphonec with '-d 6', and iLBC codec is successfully loaded.

BTW, I'm not sure what is missing in CentOS 5.1 on which I couldn't compile Linphone-2.1.1 Gtk interface. Fortunately, I could succeed compiling it on FedoraCore 8.

I'm currently studying how to write a Linphone plugin for a new Codec, such as G.729 or G.723. So I'd be very grateful if anyone who is experienced on that could provide me some guides... ^^;;

Hope this helps!


On 4/9/08, Stephen Stocker <address@hidden> wrote:

 I'm still wondering if anyone has found a way around the ilbc plugin error with Linphone. I'm also curious about the advantages or disadvantages of ilbc over gsm? Living far out in the country, I'm on a slow dial-up connection, so bandwidth is the primary concern. GSM isn't bad, but from what I understand of ilbc, it would be a better solution.

 In any event, no matter what I've tried, I still get the error below when running linphonec -d6 -l linphone.log. The libs build fine, as does the plugin itself. I had thought that perhaps the plugin wasn't finding the main header files, so as a test, I tried removing the 2 includes in ilbc.c. Doing that causes it to not compile at all, as would be expected.

 Any help would be greatly appreciated. :)



 ortp-message-oRTP-0.14.2 initialized.
 ortp-message-Registering all filters...
 ortp-message-Registering all soundcard handlers
 ortp-message-Card ALSA: default device added
 ortp-message-Card ALSA: Intel 82801BA-ICH2 added
 ortp-message-Card OSS: /dev/dsp added
 ortp-message-Card OSS: /dev/dsp added
 ortp-message-Card OSS: /dev/dsp0 added
 ortp-message-Card OSS: /dev/dsp1 added
 ortp-message-Card OSS: /dev/dsp2 added
 ortp-message-Card OSS: /dev/dsp3 added
 ortp-message-Loading plugins
 ortp-message-Loading plugin
 ortp-warning-Fail to load plugin
 /usr/local/lib/mediastreamer/plugins/ :
 /usr/local/lib/mediastreamer/plugins/ undefined symbol:
 ortp-message-ms_init() done


Linphone-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]