[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] linphone2: SIP Contact sent to registrar uses wrong IP

From: Chris Seekamp
Subject: [Linphone-users] linphone2: SIP Contact sent to registrar uses wrong IP address
Date: Fri, 11 Apr 2008 09:56:39 -0400
User-agent: Thunderbird (X11/20080227)

I am using linphone2 2.0.1-3 (hardy) and running into a problem that I did not have on the original (version 1) linphone. I cannot get linphone to use the IP address assigned by the VPN (tun0) instead of eth0 when registering. I have tried editing the ~/.gconf/linphone file and specified:


in the [net] section to no affect. I also tried to "use_nat=1" which was what I think was used in version 1. I have also tried putting the IP address in the contact field in the [sip] section, but this apparently is not being used. I tried doing everything via the GUI as well.

Basically no matter what I do, the Contact field I see sent to the Registrar has a 192.168.... address assigned by my router rather than the address I need it to use.

Again, this used to work in linphone version 1. I need to use version 2 for other reasons.

Anyone have a workaround for this? I need to specify the address (or interface). I cannot use STUN.


Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]