[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] Linphone behavioral problems

From: alex
Subject: [Linphone-users] Linphone behavioral problems
Date: Wed, 23 Apr 2008 16:16:15 +1000
User-agent: Thunderbird (X11/20080212)

Hi Guys,

Finally I got Linphone to build under freebsd.

Though I get some very strange behaviour. I am using the console version of the program.

Here's the output when I run the program (with debugging turned on level 6)

address@hidden ~]$ linphonec -d 6
NLS disabled.
INFO: no logfile, logging to stdout
ortp-message-oRTP-0.14.2 initialized.
ortp-message-Registering all filters...
ortp-message-Registering all soundcard handlers
ortp-message-Card OSS: /dev/dsp added
ortp-message-Card OSS: /dev/dsp added
ortp-message-Card OSS: /dev/dsp0 added
ortp-message-Loading plugins
ortp-message-Cannot open directory /usr/local/lib/mediastreamer/plugins: No such file or directory
ortp-message-ms_init() done
ortp-message-DNS resolution with
ortp-message-getaddrinfo returned the following addresses:
ortp-message- port 5060
Warning: video is disabled in linphonec.
linphonec> ortp-message-eXosip: Reseting timer to 15s before waking up!
ortp-message-eXosip: Reseting timer to 15s before waking up!


Now it gets strange because once I run the program, it does not respond to keyboard input. Its completely ignored. The only way to exit the program is via CTRL-C, after which, my terminal is messed up. Keystroked are no longer echoe'd at the shell prompt and backspace key just generates control character sequences. Issuing the "reset" command gives me back the echo when typing but backspace remains screwed and I need to start a new shell.

Whats with this?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]