[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] Compiling msx264 error

From: Tafoni, Theodoros Mr CTR USA AMC
Subject: [Linphone-users] Compiling msx264 error
Date: Fri, 19 Sep 2008 08:00:44 -0400

I downloaded the latest version and started to compile all the varvious
components.  Everthing compiled except for the msx264 plug-in.  The
single source file makes calls two (2) functions that don't exist.

Here's a summary:

In msx264.c, the function enc_preprocess() makes calls to functions that
don't exist. At lines 72 & 73, function calls rfc3983_set_mode() and
rfc3984_enable_stap_a(). Looking in rfc3984.h, there are only four
function prototypes and none correspond to the previous functions
listed. This was using the msx264-1.1.1 version.

I tried compiling the msx264-1.1.2 version.  This version had the same
compilation errors and added a new one.  At line 487, function
b64_decode() doesn't exist (at least with the distribution I
downloaded).  At the top of the msx264.c file, there is an include for
<ortp/b64.h> which doesn't exist in the Linphone version of libortp.
When I searched for another version of libortp, it didn't have b64.h

I'm assuming this was compiled prior to posting on the site for
download.  Are there any files that were inadvertently left out prior to
posting the archives?

As stated above, everything else compiles and I'm able to start linphone
w/o the x264 plug-in. Is the h264 support a recent addition that hasn't
been fully worked out?

Thanks in advance for any suggestions.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]