[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] can't compile 3.4.3 in the latest ubuntu linux

From: Ignacio Miranda
Subject: [Linphone-users] can't compile 3.4.3 in the latest ubuntu linux
Date: Sun, 2 Oct 2011 12:18:11 +0000


I hit an issue compiling the mediastreamer2, the linux/videodev.h is not found. I read some articles and it seems support for libv4l1 is being dropped form the kernel for latest versions, although for some reason linphone detects it. I see videodev.h is included no matter what, ie. no #ifdef around it, and some extra code also uses it.

I have libv4l-dev 0.8.x installed which results in libv4l2, I tried to compile and install a suppossed libv4l1 version I found, it actually had both 1, 2 and convert, libraries, but libv4l1 doesn't build, throws the same error videodev.h is not found, I am out of ideas trying to compile this.

Got the current development version with git, but there is no config or makefile and no info on how to build it, so I am lost trying to configure it, any help would be great.

I currently have linphone 3.3.2 installed, the latest pre-built package for ubuntu, but unfortunatly when I make a call with video it hangs, well it does make the call, but when it is answered by the far end (windows 3.4.3) it hangs the linux originating side and has to be killed. Note the selfview from the cam before making the call works fine.

Again any help would be greatly appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]