[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] Call failed to certain numbers

From: Christopher Woods
Subject: Re: [Linphone-users] Call failed to certain numbers
Date: Tue, 8 Jan 2019 18:18:14 +0000

488 not acceptable here can be due to codec problems. In the SDP in the initial invite, I don't see any G.711 A-law or U-law (aka PCMA/PCMU) listed - only Speex, iLBC, AAC and Opus plus the usual signalling telephone-event stuff.

Chances are your new telco provider may not wish to transcode to G.711, so is refusing the set up? Settings -> Audio -> PCMU/PCMA at the bottom. I'd expect to see
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000

in the SDP from your client along with all the other codecs, if calling SIP to PSTN, as fallback codecs. Further confirmed by their wiki --

peoplefone supports the codecs G711a/u, G722, G729. We also support the T-38 protocol for fax. (Please contact us, if you want to use it.)

Please try to follow the order in the configuration if possible:
  • g711a
  • g711u
  • g722
  • g729

Sidenote - although you appear to already have it disabled, if you have problems establishing calls in future make sure you the video feature is disabled ("always use video" on the desktop, "Enable video" in the mobile client).

Video requires RTP/AVPF profiles to be sent in the SDP, which some SIP proxies don't like. Your invite appears to be OK though (RTP/AVP), except for the lack of G.711 codecs advertised in your INVITE.

On Tue, 8 Jan 2019 at 09:04, Andi Soko <address@hidden> wrote:
Hi Sylvain,

Sorry, I've made a wrong assumption. I had an old SIP line from a 
different provider in Linphone and didn't know that dailing from the 
history also dails the old provider.

So the real issue is apparently:
I cannot dail international numbers with Linphone and
Non-international numbers work! With an other App (Zioper) or another SIP 
line ( everything works.
- Changing the setting "Subsitute + in phone number" doesnt make a 
- In the setting "Country code prefix" (if this setting is from 
importance) I have tried "+43", "0043" and "0" (country I'm in). Somehow 
it doesnt take "" as an entry.

The error is still the same:
Call failed
Cannot call + +4935...9915
Reason was: Not Acceptable Here
[Media Descriptions Syntax error while parsing the SDP]

Find attached the log file.


On Tue, 08 Jan 2019 09:43:30 +0100, Sylvain Berfini 
<address@hidden> wrote:

> Hi Soko,
> Can you attach the logs starting from the INVITE sent to the server at 
> to the moment you have the media description syntax error 
> please ?
> Thanks.
> Le 08/01/2019 à 09:39, Andi Soko a écrit :
>> Hey guys,
>> I have linphone installed and using the a SIP line from
>> I mainly call customers in Germany and when I call their official/main 
>> number "+4935...9926" everything works.
>> But when I call an extension-number to get to a specific person 
>> (+4935...9915) I get the following error:
>> Call failed
>> Cannot call + +4935...9915
>> Reason was: Not Acceptable Here
>> [Media Descriptions Syntax error while parsing the SDP]
>> When I use another SIP client app (i.e. Zioper) with the same SIP line 
>> all numbers are working. But I like linphone interface and would like 
>> to use it :)
>> can anyone give me some hints were to look at or which option to change?
>> thanks
>> Soko
>> _______________________________________________
>> Linphone-users mailing list
>> address@hidden
> _______________________________________________
> Linphone-users mailing list
> address@hidden
Linphone-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]