lmi-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lmi-commits] [lmi] master updated (6977670 -> 713d56f)


From: Greg Chicares
Subject: [lmi-commits] [lmi] master updated (6977670 -> 713d56f)
Date: Wed, 22 Jul 2020 11:05:07 -0400 (EDT)

chicares pushed a change to branch master.

      from  6977670   Upgrade wxWidgets and wxPdfDoc
       new  193e804   Refactor census view to enable several implementations
       new  3e9f8af   Add census_view variant with wxGrid
       new  14ac975   Use at() instead of operator[] in 
non-performance-critical code
       new  804111d   Remove unnecessary use of std::swap()
       new  c094807   Remove unnecessary altColor_ member variable
       new  3d86a92   Use simpler wxGrid::AssignTable()
       new  d39ff1d   Use wxGridCellAttrPtr instead of manual reference counting
       new  c9e743f   Remove extra blank line from census_view.hpp
       new  12940dc   Define static map in more compact way
       new  25a989e   Make table_type_converter::get_all() map const
       new  ba15191   Stop using wxRTTI in DatumSequenceEditorEvtHandler
       new  e1fdb77   Use Bind() in DatumSequenceEditorEvtHandler
       new  5ee4b04   Improve comments in DatumSequenceEditorEvtHandler
       new  03d33ab   Make DatumSequenceEditorEvtHandler::entry_ const
       new  7e048d0   Remove apparently unnecessary wxEVT_CHAR handler
       new  0e2a694   Replace DatumSequenceEditorEvtHandler with a lambda
       new  ece93a0   Make check for Alt-Enter more obvious in the code
       new  b57ed4a   Remove deleted DatumSequenceEditor copy-related methods
       new  c679655   Replace table_type_converter::get_all() with 
register_all()
       new  6281a6d   Make object returned by table_type_converter::get_impl() 
const
       new  7b62d49   Rename table_type_converter::get_by_value() to just get()
       new  1dacd5c   Move register_all() to table_custom_type_converter
       new  a43eb0f   Add a comment explaining register_all() approach
       new  b85da3e   Clarify the comment about CensusViewDataViewModel wrappers
       new  5423df7   Remove separate table_type_converter::type()
       new  810de0a   Remove unnecessary wxGrid::IsCellEditControlEnabled() 
calls
       new  342b9f5   Always resize columns in 
CensusGridView::update_visible_columns()
       new  adc4089   Optimize changing grid dimensions when pasting into the 
census
       new  f217203   Rename "columns_count" to "old_columns_count" for 
consistency
       new  041ccfc   Optimize changing grid columns number too
       new  f82b136   Remove unnecessary make_cell_number_column_read_only() 
function
       new  be4c2a4   Add a comment explaining why the first column is read-only
       new  53a288a   Restore "delete_cells" update UI handler for CensusDVCView
       new  4dcae52   Don't change default wxGrid lines colour
       new  7dc508e   Don't select the first row initially in the grid census 
view
       new  3c3d0c0   Explain grid customizations in the function creating it
       new  337d81f   Make UponDeleteCells() more efficient for large censuses
       new  b7944ba   Resize only columns, not rows, in update_visible_columns()
       new  9f1cb2e   Only auto-size columns when they change, not after each 
update
       new  b399a7d   Remove automatic column auto-sizing in wxGrid-based 
census view
       new  395e268   Remove unnecessary calls to Update() when toggling 
autosize
       new  d4ad57b   Disallow "Edit/Run" cell when multiple grid rows are 
selected
       new  b3ac65b   Allow wxGrid to compute census view column sizes more 
efficiently
       new  2922db9   Disallow single cell operations when non-current row is 
selected
       new  d337a22   Upgrade wx
       new  713d56f   Fix defect introduced 20200608T2219Z: warning not 
suppressed


Summary of changes:
 census_document.cpp         |   17 +-
 census_document.hpp         |   35 +-
 census_view.cpp             | 1409 ++++++++++++++++++++++++++++++++++++++++++-
 census_view.hpp             |  140 ++++-
 input_sequence_entry.cpp    |   27 +-
 input_sequence_entry.hpp    |    2 +
 install_wx.sh               |    2 +-
 skeleton.cpp                |    6 +-
 workhorse.make              |    6 +
 wx_test_paste_census.cpp    |  263 ++++++--
 wx_test_validate_output.cpp |   18 +-
 11 files changed, 1803 insertions(+), 122 deletions(-)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]