lmi
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lmi] [lmi-commits] master 7dd2680 14/14: Add and use a forward-summ


From: Vadim Zeitlin
Subject: Re: [lmi] [lmi-commits] master 7dd2680 14/14: Add and use a forward-summation function template
Date: Sat, 20 Feb 2021 15:49:36 +0100

On Thu, 18 Feb 2021 12:03:42 -0500 (EST) Greg Chicares 
<gchicares@sbcglobal.net> wrote:

GC> branch: master
GC> commit 7dd2680044d48d794d1e68e087d0795ea70b2525
GC> Author: Gregory W. Chicares <gchicares@sbcglobal.net>
GC> Commit: Gregory W. Chicares <gchicares@sbcglobal.net>
GC> 
GC>     Add and use a forward-summation function template
GC>     
GC>     Incidentally, this commit will make it simpler to
GC>       s/partial_sum/inclusive_scan/
GC>     once gcc is upgraded from version 8 for lmi production.

 I'm curious if using inclusive_scan() rather than partial_sum() can change
the results in practice. I know that in theory it could, due to the
floating point addition operation not being associative, but I haven't
actually tried confirming this experimentally and so I don't really know if
there could be a noticeable effect.

 Also, as usual, I don't know what is the typical size of the vectors this
code works with. If it's smallish, it's probably not even worth bothering
with checking whether inclusive_scan() could be used here or not as it's
not going to provide any significant gains over partial_sum() anyhow. But
if the vectors can be really big, it could be interesting to explore using
a parallel (unsequenced?) policy.

 Regards,
VZ

Attachment: pgpaJxjv5IatK.pgp
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]