lwip-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, up


From: Sylvain Rochet
Subject: [lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, updated. STABLE-2_1_0_RELEASE-446-gc18a8dc
Date: Mon, 19 Oct 2020 23:41:53 -0400 (EDT)

This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "lwIP - A Lightweight TCPIP stack".

The branch, master has been updated
       via  c18a8dc9cc113c78475f5310abe83ccd50352374 (commit)
       via  b2d1fc119d50f0f9a9f2edb784577f9ad6585fbe (commit)
       via  7f91a71eca83f41ca5855029c28308772c8c96ec (commit)
       via  34156e059461211ee0f74f6c278bb68f6fc9bac7 (commit)
       via  5ad2f06333eacdff23d4b6d8edc6594da25bb651 (commit)
       via  c5021bdc4d12ce3b1bf75652367acb9d84960d08 (commit)
       via  3b5775071531237ea13e3b41595c03d085fb5cfe (commit)
       via  9b7cba9643c1d8d32b6549eed67f1a6cbde1b791 (commit)
       via  6584002826e39589d7972966a4e44e06472f44c9 (commit)
       via  e8013077389e9b4744f15a4cb1bac3e56c45485e (commit)
       via  a39ce0f53b2a57c4e7fbb252efb579a629201868 (commit)
       via  51c6548631dab543ecbb903e8644b73c54e5bdcd (commit)
       via  90874392e330e6c6bf552b349a8ae176708595c2 (commit)
       via  b8640678d65d6749cef931c2455ef7fcf5db5cec (commit)
       via  331fe2dea2deff773cea9db38b48a9eafb575f8e (commit)
       via  7633c24213279e0e0095b56f75ed34b9a5ffdcbf (commit)
       via  39cb84466dbcd2b55b9f417a0ddaf411ef3bf08d (commit)
      from  012fadd77f35b7bc4475f2c296a5101cea64a9a6 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit c18a8dc9cc113c78475f5310abe83ccd50352374
Author: Freddie Chopin <freddie.chopin@gmail.com>
Date:   Thu Dec 5 22:14:09 2019 +0100

    PPP, PPPoS: Remove useless cast from pppos_output_append() and 
pppos_output_last()
    
    pppos_output_cb_fn() now takes `const void*`, so there is no need to
    cast the payload (`void*`) to anything else.

commit b2d1fc119d50f0f9a9f2edb784577f9ad6585fbe
Author: Freddie Chopin <freddie.chopin@gmail.com>
Date:   Thu Dec 5 22:12:45 2019 +0100

    PPP, PPPoS: Use `const void*` instead of `u8_t*` in pppos_output_cb_fn()
    
    There is no good reason why this function should take a non-const
    pointer, as the output callback should never modify what lwIP gives it.
    While changing that also switch to a more generic `void*` instead of
    "byte".

commit 7f91a71eca83f41ca5855029c28308772c8c96ec
Author: Freddie Chopin <freddie.chopin@gmail.com>
Date:   Thu Dec 5 22:13:02 2019 +0100

    Contrib, PPP: Remove trailing whitespaces in pppos_example.c

commit 34156e059461211ee0f74f6c278bb68f6fc9bac7
Author: Freddie Chopin <freddie.chopin@gmail.com>
Date:   Thu Dec 5 22:02:33 2019 +0100

    PPP, PPPoS: Remove useless cast from pppos_input_sys()
    
    pppos_input() now takes `const void*`, so there is no need to cast the
    payload (`void*`) to anything else.

commit 5ad2f06333eacdff23d4b6d8edc6594da25bb651
Author: Freddie Chopin <freddie.chopin@gmail.com>
Date:   Thu Dec 5 22:01:05 2019 +0100

    PPP, PPPoS: Use `const void*` instead of `u8_t*` in pppos_input()
    
    There is no good reason why this function should take a non-const
    pointer. While changing that also switch to a more generic `void*`
    instead of "byte".

commit c5021bdc4d12ce3b1bf75652367acb9d84960d08
Author: Freddie Chopin <freddie.chopin@gmail.com>
Date:   Thu Dec 5 21:57:39 2019 +0100

    PPP, PPPoS: Use `const void*` instead of `u8_t*` in pppos_input_tcpip()
    
    There is no good reason why this function should take a non-const
    pointer. While changing that also switch to a more generic `void*`
    instead of "byte".

commit 3b5775071531237ea13e3b41595c03d085fb5cfe
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Tue Oct 20 04:15:25 2020 +0200

    PPP: remove LWIP_ASSERT_CORE_LOCKED on ppp_set_auth function
    
    We do not have equivalents in PPPAPI for ppp_set_* functions because
    calling them only makes sense while session is disconnected, furthermore
    they are only setting structure members of the session configuration.

commit 9b7cba9643c1d8d32b6549eed67f1a6cbde1b791
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Tue Oct 20 03:57:36 2020 +0200

    PPP: don't define PPP_IP if PPP_IPV4_SUPPORT is disabled
    
    Doing so helps a lot at finding places where we have leftovers of IPv4
    support when the support is disabled.

commit 6584002826e39589d7972966a4e44e06472f44c9
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Tue Oct 20 03:17:53 2020 +0200

    PPP, PPPoS: only reserve header space for IPv4 and IPv6 packets if IP 
forwarding is enabled
    
    We only have to reserve header space for forwarding for IPv4 and IPv6
    packets, all other packets are PPP control packets. Doing so reduce
    the need of having to coalesce the PBUF chain before PPP processes
    control packets.

commit e8013077389e9b4744f15a4cb1bac3e56c45485e
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Tue Oct 20 02:53:46 2020 +0200

    PPP: set mtu6 too when setting PPP netif MTU
    
    PPP peer can negotiate its MRU, therefore we don't know the MTU we are
    going to use before starting PPP. This is an issue because netif_add
    function assume that the netif init callback function will set the MTU,
    netif_add will then copy mtu to mtu6. We have then to update mtu6 each
    time we update mtu to keep them in sync. Doing so is fine because PPP
    netif MTU is only updated when the netif is in link down state.

commit a39ce0f53b2a57c4e7fbb252efb579a629201868
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Mon Oct 19 20:22:05 2020 +0200

    PPP, PPPoS: drop input packets much bigger than our MRU
    
    Our current HDLC decoder does not protect against starving the Rx
    PBUF POOL for one packet, most likely due to received garbage on
    the serial port.
    
    Prevent starving the Rx pool by checking incoming packets length
    against PPP_MRU with a 10% margin because we only want to avoid
    filling all PBUFs with garbage, we don't have to be pedantic.
    
    Fixes bug #58441: Invalid PPP data accumulates forever.

commit 51c6548631dab543ecbb903e8644b73c54e5bdcd
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Mon Oct 19 00:26:14 2020 +0200

    PPP: allow negotiating MRU with PPP_MRU config option
    
    PPP_MRU is now free to be used for what it should have been. Now using
    it at PPP init stage to set the wanted MRU value, triggering a MRU
    negotiation at the LCP phase.
    
    I doubt anyone needs it anyway, but, well, at least it is fixed and the
    MRU/MTU config mess is cleaned.
    
    And while we are at it, better document PPP MRU config values.

commit 90874392e330e6c6bf552b349a8ae176708595c2
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Sun Oct 18 23:30:58 2020 +0200

    PPP: force default MRU to 1500
    
    RFC1661 mandates that default MRU value, that must be used prior
    negotiation of MRU value and if MRU value is not negotiated later, must
    be 1500.
    
    That is, any PPP host must accept control frames of at least 1500 when
    the PPP session start (there are no way to split them in multiples
    frames anyway) and must use a value of 1500 if MRU is no negotiated
    during LCP exchanges.
    
    Therefore, having it configurable in ppp_opts is a mistake. It was wrong
    and never worked because changing the value never triggered a MRU value
    negotiation because it changed both the wanted MRU value and the RFC
    default value to which the wanted value is compared to trigger a MRU
    negotiation if values are not equal.

commit b8640678d65d6749cef931c2455ef7fcf5db5cec
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Sun Oct 18 22:26:39 2020 +0200

    PPP, LCP: merge PPP_MRU into PPP_DEFMRU
    
    This is actually the same thing, both values are used interchangeably in
    various places but their value must be the same.

commit 331fe2dea2deff773cea9db38b48a9eafb575f8e
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Sun Oct 18 21:11:33 2020 +0200

    PPP: rename netif_set/get_mtu to ppp_netif_set/get_mtu
    
    Those are private functions, using the netif_ prefix here is not really
    nice, especially with functions named netif_set_mtu and netif_get_mtu
    for obvious reasons.

commit 7633c24213279e0e0095b56f75ed34b9a5ffdcbf
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Sun Oct 18 17:10:13 2020 +0200

    PPP, PPPoE, PPPoL2TP: remove persistent retries if sending packets fails
    
    We currently retry indefinitely if sending packets fails, for example
    if the output interface is down. We are even doing it if we are in
    a middle of a connection process. This is not a very nice behavior
    because PPP low level will retry indefinitely to connect and the user
    application will never be warned that something is wrong.
    
    We have the persist boolean in PPP settings to achieve more or less
    the same thing anyway. Except it does it better at only retrying
    indefinitely the initiation packet.

commit 39cb84466dbcd2b55b9f417a0ddaf411ef3bf08d
Author: Sylvain Rochet <gradator@gradator.net>
Date:   Sun Oct 18 16:38:14 2020 +0200

    PPP: remove PPP_USE_PBUF_RAM configuration option
    
    Having it configurable does not really make sense anymore, we already
    need PBUF_RAM in all transmit paths. There are no real reason to keep
    allocating PPP response buffers from the PBUF_POOL which should be now
    reserved for receive paths only.

-----------------------------------------------------------------------

Summary of changes:
 contrib/examples/example_app/test.c  |  4 +--
 contrib/examples/ppp/pppos_example.c | 28 ++++++++---------
 doc/ppp.txt                          |  2 +-
 src/include/netif/ppp/ppp_impl.h     | 22 +++++++------
 src/include/netif/ppp/ppp_opts.h     | 39 +++++++++--------------
 src/include/netif/ppp/pppos.h        |  6 ++--
 src/netif/ppp/ccp.c                  |  4 +--
 src/netif/ppp/chap-new.c             |  6 ++--
 src/netif/ppp/demand.c               | 10 +++---
 src/netif/ppp/eap.c                  | 16 +++++-----
 src/netif/ppp/fsm.c                  |  4 +--
 src/netif/ppp/lcp.c                  | 24 +++++++--------
 src/netif/ppp/multilink.c            | 10 +++---
 src/netif/ppp/ppp.c                  | 21 +++++++------
 src/netif/ppp/pppoe.c                |  2 --
 src/netif/ppp/pppol2tp.c             |  4 ---
 src/netif/ppp/pppos.c                | 60 ++++++++++++++++++++++++++++++------
 src/netif/ppp/upap.c                 |  4 +--
 18 files changed, 149 insertions(+), 117 deletions(-)


hooks/post-receive
-- 
lwIP - A Lightweight TCPIP stack



reply via email to

[Prev in Thread] Current Thread [Next in Thread]