[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [lwip-users] [PATCH 1/7] lwip: config sanity check for NETIP
From: |
Frédéric BERNON |
Subject: |
Re: [lwip-users] [PATCH 1/7] lwip: config sanity check for NETIP |
Date: |
Fri, 21 Sep 2007 11:14:44 +0200 |
>[lwip-users] [PATCH 1/7] lwip: config sanity
check for NETIP
Simon is right, the best use should be something
like "#if (LWIP_NETIF_API && NO_SYS)"
> [lwip-users] [PATCH 2/7] lwip: report out of
memory by pool name in debug
Ok for me
> | [lwip-users] [PATCH 3/7] lwip: fix
warning in debug msg |
Ok for me
>
[lwip-users]
[PATCH 4/7] lwip: fix warning 'code has no effect' where mem_realloc was
used |
To be honest, since we could/should(?) use
mem_realloc like this : "pr = mem_realloc(p,x)", your change doesn't
work.
About the comment, it's "trivial", but a comment
never kill everyone.
> | [lwip-users] [PATCH 5/7] lwip: fix build error with
LWIP_UDP=0
Ok for me
>
[lwip-users] [PATCH 6/7] lwip: fix warning: 'packed' attribute
ignored
I'm agree with Simon: seems strange to my point of
view.
> | [lwip-users] [PATCH 7/7] lwip:
formatting chagne to make LWIP_DEBUGF more readable
I would prefer something like that (with each
part of the _expression_ on one line):
#define LWIP_DEBUGF(debug,x) \
do { \
if (((debug) & LWIP_DBG_ON)
&& \
((debug)
& LWIP_DBG_TYPES_ON) && \
((s16_t)((debug)
& LWIP_DBG_MASK_LEVEL) >= LWIP_DBG_MIN_LEVEL)) { \
LWIP_PLATFORM_DIAG(x);
\
if ((debug) & LWIP_DBG_HALT) { \
while(1); \
} \
} \
} while(0)
If no objections, I can check in 1, 2, 3, 5, &
7 this afternoon. Ok for you?
----- Original Message -----
Sent: Friday, September 21, 2007 8:19
AM
Subject: RE: [lwip-users] [PATCH 1/7] lwip: config
sanity check for NETIP
[re: config sanity check for NETIP] > +#if (LWIP_NETIF_API
&& !LWIP_TCP) > + #error "NETIF API is for TCP" >
+#endif
Why would LWIP_NETIF_API depend on LWIP_TCP? Don't get confused
with tcpip.c vs. tcp.c! Tcpip.c mainly contains a
multithreading-wrapper for the lwIP core and has nothing to do with the TCP
protocol implementation.
[re: report out of memory by pool name
indebug:] If that works, it's a good idea for debugging, I think.
[re:
fix build error with LWIP_UDP=0] I'd rather rely on a check in init.c to
solve this.
[re: fix warning: 'packed' attributeignored] That's
strange, I think. I've never seen a compiler warn about this. But then again,
I haven't used gcc4 so far. Can't you simply turn that warning off? I'm using
gcc3 and there are some warnings I can't use When compiling the lwip
code...
Simon
_______________________________________________ lwip-users
mailing list address@hidden http://lists.nongnu.org/mailman/listinfo/lwip-users
- [lwip-users] [PATCH 1/7] lwip: config sanity check for NETIP, address@hidden, 2007/09/20
- RE: [lwip-users] [PATCH 1/7] lwip: config sanity check for NETIP, Goldschmidt Simon, 2007/09/21
- Re: [lwip-users] [PATCH 1/7] lwip: config sanity check for NETIP, Andrew Dennison, 2007/09/22
- Re: [lwip-users] [PATCH 1/7] lwip: config sanity check for NETIP, Frédéric BERNON, 2007/09/22
- Re: [lwip-users] [PATCH 1/7] lwip: config sanity check for NETIP, Andrew Dennison, 2007/09/22
- RE: [lwip-users] [PATCH 1/7] lwip: config sanity check for NETIP, Goldschmidt Simon, 2007/09/24
| |