[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[MIT-Scheme-devel] Re: Problem running scheme 20090107 in fedora 12

From: Aaron W. Hsu
Subject: [MIT-Scheme-devel] Re: Problem running scheme 20090107 in fedora 12
Date: Wed, 06 Jan 2010 15:02:51 -0500
User-agent: Opera Mail/10.10 (Linux)

On Tue, 05 Jan 2010 18:19:30 -0500, oliver bunnin <address@hidden> wrote:

I've downloaded from
checked that the md5sum was correct, then followed the instructions on
the webpage:
I get the following error when I run scheme:

address@hidden local]# scheme
scheme: error while loading shared libraries: cannot open
shared object file: No such file or directory

I did a check with find and got:
where ./ = /usr/local/lib

I tried renaming as but got the same error message,
this was having set the path to include /usr/local/lib/mit-scheme/lib/ .

Any idea what I'm doing wrong?

You don't want to do what you just did. Those shared object files are for interfacing with the gdbm library that is installed on your system. Instead, you need to locate where the gdbm libraries exist on your system and find out why they were not identified by MIT Scheme. Use a locate and search for, and if you cannot find it, well, then that's your problem! You should install the gdbm package if you do not already have it installed. Usually, if you compile MIT Scheme, you can choose whether or not to install this package, but I don't know how it works with this particular packaging. It has been a while since I used MIT Scheme.

        Aaron W. Hsu

A professor is one who talks in someone else's sleep.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]