[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [MIT-Scheme-devel] problem with md5 checksum for OSX binary of mit-s

From: David Adelson
Subject: Re: [MIT-Scheme-devel] problem with md5 checksum for OSX binary of mit-scheme
Date: Thu, 9 Mar 2017 14:34:39 -0800

very helpful…tx 

> On Mar 9, 2017, at 12:59 PM, Aaron S. Hawley <address@hidden> wrote:
>> i just downloaded
>> in order to install mit-scheme on my macbook running OS X
> I'm not a maintainer of MIT/GNU Scheme, but I downloaded and installed
> using that file, too.
>> i ran SHASUM on the file, and got the following checksum:
>> 31527ad2d3cfb474ab035fb1aff6b2eda2c126a9
> That's what I get, too, when I run sha1sum
>> this does not match the checksum listed for the file at
>>, which is as
>> follows:
>> 57155daa9fd5bf260449d5d1e9587507  mit-scheme-9.2-x86-64.dmg
> When I run it with md5sum, I get that, too.
> I think you're running the wrong hash program.
>> coincidentally, i recently downloaded and installed this same package on my
>> iMac running OS X, and ran into a bunch of problems with the system hanging,
>> locking up, etc.  i had to re-install XQuartz to resolve the problems…a day
>> later the logic board on my iMac failed.  i have no idea whether there was
>> any connection, but i wanted to mention it just in case there is a problem
>> with a malicious bit of code.
> Coincidentally, I was running scheme in Emacs in Scheme mode with the
> mit-scheme program, but then forgot about it, and it ran away with all
> the CPU after a a couple of weeks.  I'm a lot more mindful now.
>> in any case, i do not want to install the package since the checksums don’t
>> match.  any guidance appreciated
> There may be a defect, but I don't think it's malicious.
> Sorry about your loss.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]