[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [octave:code] [r11948] - gedeone-octave: Changed the name of the fun
From: |
c. |
Subject: |
Re: [octave:code] [r11948] - gedeone-octave: Changed the name of the function to mshm_dolfin_read Added a demo Try to follow the Octave code formatting guidelines |
Date: |
Sun, 9 Jun 2013 21:51:39 +0200 |
Hi Marco,
I just noticed your commit:
> http://sourceforge.net/p/octave/code/11948/
On 9 Jun 2013, at 19:58, Repository Octave Forge code <address@hidden> wrote:
> Changed the name of the function to mshm_dolfin_read
> Added a demo
> Try to follow the Octave code formatting guidelines
your code still does not comply with the style guidlines,
here are some examples of things you should change:
if( D == 2) e.resize(7,num_f);
this should be formatted as
if (D == 2)
e.resize (7, num_f);
while
std::string mesh_to_read = args(0).string_value();
should be
std::string mesh_to_read = args(0).string_value ();
i.e.
1) leave a space before opening parentheses when calling a function or a method
don't leave the space if indexing an array
2) add a space after a comma
3) don't leave a space after an open parenthesis and before the closing
paranthesis
also your docstring is still plain text and not texinfo.
c.
[Prev in Thread] |
Current Thread |
[Next in Thread] |
- Re: [octave:code] [r11948] - gedeone-octave: Changed the name of the function to mshm_dolfin_read Added a demo Try to follow the Octave code formatting guidelines,
c. <=