[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 06/10] exec: Move ramblock_recv_bitmap_offset() to migration/ram.
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH 06/10] exec: Move ramblock_recv_bitmap_offset() to migration/ram.c |
Date: |
Thu, 7 May 2020 19:39:54 +0200 |
The ramblock_recv_bitmap_offset() function is only used once
in migration/ram.c, move it there.
Signed-off-by: Philippe Mathieu-Daudé <address@hidden>
---
include/exec/ram_addr.h | 8 --------
migration/ram.c | 8 ++++++++
2 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/include/exec/ram_addr.h b/include/exec/ram_addr.h
index 195b67d3c8..c61d5188f7 100644
--- a/include/exec/ram_addr.h
+++ b/include/exec/ram_addr.h
@@ -83,14 +83,6 @@ static inline void *ramblock_ptr(RAMBlock *block, ram_addr_t
offset)
return (char *)block->host + offset;
}
-static inline unsigned long int ramblock_recv_bitmap_offset(void *host_addr,
- RAMBlock *rb)
-{
- uint64_t host_addr_offset =
- (uint64_t)(uintptr_t)(host_addr - (void *)rb->host);
- return host_addr_offset >> TARGET_PAGE_BITS;
-}
-
bool ramblock_is_pmem(RAMBlock *rb);
/**
diff --git a/migration/ram.c b/migration/ram.c
index 53166fc279..0cd16d0519 100644
--- a/migration/ram.c
+++ b/migration/ram.c
@@ -190,6 +190,14 @@ int foreach_not_ignored_block(RAMBlockIterFunc func, void
*opaque)
return ret;
}
+static inline unsigned long int ramblock_recv_bitmap_offset(void *host_addr,
+ RAMBlock *rb)
+{
+ uint64_t host_addr_offset =
+ (uint64_t)(uintptr_t)(host_addr - (void *)rb->host);
+ return host_addr_offset >> TARGET_PAGE_BITS;
+}
+
static void ramblock_recv_map_init(void)
{
RAMBlock *rb;
--
2.21.3
- Re: [PATCH 01/10] exec: Rename qemu_ram_writeback() as qemu_ram_msync(), (continued)
- [PATCH 02/10] exec/ramblock: Add missing 'qemu/rcu.h' include, Philippe Mathieu-Daudé, 2020/05/07
- [PATCH 03/10] exec: Move tb_invalidate_phys_range() to 'exec/exec-all.h', Philippe Mathieu-Daudé, 2020/05/07
- [PATCH 04/10] exec/memory-internal: Check CONFIG_SOFTMMU instead of CONFIG_USER_ONLY, Philippe Mathieu-Daudé, 2020/05/07
- [PATCH 05/10] exec: Move qemu_minrampagesize/qemu_maxrampagesize to 'qemu-common.h', Philippe Mathieu-Daudé, 2020/05/07
- [PATCH 06/10] exec: Move ramblock_recv_bitmap_offset() to migration/ram.c,
Philippe Mathieu-Daudé <=
- [PATCH 07/10] exec: Move all RAMBlock functions to 'exec/ramblock.h', Philippe Mathieu-Daudé, 2020/05/07
- [PATCH 08/10] hw/block: Let the NVMe emulated device be target-agnostic, Philippe Mathieu-Daudé, 2020/05/07
- [PATCH 09/10] exec: Update coding style to make checkpatch.pl happy, Philippe Mathieu-Daudé, 2020/05/07