[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH-for-5.2 1/7] hw/block/fdc: Let sector count be unsigned
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH-for-5.2 1/7] hw/block/fdc: Let sector count be unsigned |
Date: |
Thu, 6 Aug 2020 10:08:18 +0200 |
Sectors count can not be negative, make it unsigned.
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
---
hw/block/fdc.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/hw/block/fdc.c b/hw/block/fdc.c
index e9ed3eef45..2cec7568c1 100644
--- a/hw/block/fdc.c
+++ b/hw/block/fdc.c
@@ -245,14 +245,14 @@ static void fd_init(FDrive *drv)
#define NUM_SIDES(drv) ((drv)->flags & FDISK_DBL_SIDES ? 2 : 1)
-static int fd_sector_calc(uint8_t head, uint8_t track, uint8_t sect,
- uint8_t last_sect, uint8_t num_sides)
+static uint32_t fd_sector_calc(uint8_t head, uint8_t track, uint8_t sect,
+ uint8_t last_sect, uint8_t num_sides)
{
return (((track * num_sides) + head) * last_sect) + sect - 1;
}
/* Returns current position, in sectors, for given drive */
-static int fd_sector(FDrive *drv)
+static uint32_t fd_sector(FDrive *drv)
{
return fd_sector_calc(drv->head, drv->track, drv->sect, drv->last_sect,
NUM_SIDES(drv));
--
2.21.3
- [PATCH-for-5.2 0/7] hw/block/fdc: Cleanups trying to make sense of the floppy controllers, Philippe Mathieu-Daudé, 2020/08/06
- [PATCH-for-5.2 1/7] hw/block/fdc: Let sector count be unsigned,
Philippe Mathieu-Daudé <=
- [PATCH-for-5.2 2/7] hw/block/fdc: Let sector offset be unsigned, Philippe Mathieu-Daudé, 2020/08/06
- [PATCH-for-5.2 3/7] hw/block/fdc: Use warn_report() instead of debug FLOPPY_DPRINTF() calls, Philippe Mathieu-Daudé, 2020/08/06
- [PATCH-for-5.2 4/7] hw/block/fdc: Convert debug FLOPPY_DPRINTF() to trace events, Philippe Mathieu-Daudé, 2020/08/06
- [PATCH-for-5.2 5/7] hw/block/fdc: Drop pointless FLOPPY_DPRINTF() call, Philippe Mathieu-Daudé, 2020/08/06
- [PATCH-for-5.2 6/7] hw/block/fdc: Use more descriptive TypeInfo names, Philippe Mathieu-Daudé, 2020/08/06
- [PATCH-for-5.2 7/7] hw/block/fdc: Add ASCII art schema of QOM relations, Philippe Mathieu-Daudé, 2020/08/06