qemu-block
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 05/12] hw/block/pflash_cfi02: Open-code pflash_register_me


From: David Edmondson
Subject: Re: [PATCH v2 05/12] hw/block/pflash_cfi02: Open-code pflash_register_memory(rom=false)
Date: Wed, 10 Mar 2021 17:31:01 +0000

On Wednesday, 2021-03-10 at 18:05:21 +01, Philippe Mathieu-Daudé wrote:

> There is only one call to pflash_register_memory() with
> rom_mode == false. As we want to modify pflash_register_memory()
> in the next patch, open-code this trivial function in place for
> the 'rom_mode == false' case.
>
> Reviewed-by: Bin Meng <bmeng.cn@gmail.com>
> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>

Reviewed-by: David Edmondson <david.edmondson@oracle.com>

> ---
>  hw/block/pflash_cfi02.c | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/hw/block/pflash_cfi02.c b/hw/block/pflash_cfi02.c
> index 0eb868ecd3d..897b7333222 100644
> --- a/hw/block/pflash_cfi02.c
> +++ b/hw/block/pflash_cfi02.c
> @@ -467,8 +467,10 @@ static void pflash_write(void *opaque, hwaddr offset, 
> uint64_t value,
>      switch (pfl->wcycle) {
>      case 0:
>          /* Set the device in I/O access mode if required */
> -        if (pfl->rom_mode)
> -            pflash_register_memory(pfl, 0);
> +        if (pfl->rom_mode) {
> +            pfl->rom_mode = false;
> +            memory_region_rom_device_set_romd(&pfl->orig_mem, false);
> +        }
>          pfl->read_counter = 0;
>          /* We're in read mode */
>      check_unlock0:
> -- 
> 2.26.2

dme.
-- 
And you're standing here beside me, I love the passing of time.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]