[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v3 22/26] hw/i2c/smbus_eeprom: Prefer DEFINE_TYPES() macro
From: |
Bernhard Beschow |
Subject: |
Re: [PATCH v3 22/26] hw/i2c/smbus_eeprom: Prefer DEFINE_TYPES() macro |
Date: |
Sun, 03 Nov 2024 07:51:46 +0000 |
Am 2. November 2024 17:24:25 UTC schrieb Corey Minyard <corey@minyard.net>:
>On Sat, Nov 2, 2024 at 8:25 AM Bernhard Beschow <shentey@gmail.com> wrote:
>>
>> Reviewed-by: Cédric Le Goater <clg@redhat.com>
>> Signed-off-by: Bernhard Beschow <shentey@gmail.com>
>> ---
>> hw/i2c/smbus_eeprom.c | 19 ++++++++-----------
>> 1 file changed, 8 insertions(+), 11 deletions(-)
>>
>> diff --git a/hw/i2c/smbus_eeprom.c b/hw/i2c/smbus_eeprom.c
>> index 9e62c27a1a..1d4d9704bf 100644
>> --- a/hw/i2c/smbus_eeprom.c
>> +++ b/hw/i2c/smbus_eeprom.c
>> @@ -151,19 +151,16 @@ static void smbus_eeprom_class_initfn(ObjectClass
>> *klass, void *data)
>> dc->user_creatable = false;
>> }
>>
>> -static const TypeInfo smbus_eeprom_info = {
>> - .name = TYPE_SMBUS_EEPROM,
>> - .parent = TYPE_SMBUS_DEVICE,
>> - .instance_size = sizeof(SMBusEEPROMDevice),
>> - .class_init = smbus_eeprom_class_initfn,
>> +static const TypeInfo types[] = {
>
>This is better, but why did you change the name to "types". The
>previous name was fairly descriptive, though you might change "info"
>to "types".
I took inspiration from
https://lore.kernel.org/qemu-devel/20240215175752.82828-20-philmd@linaro.org .
I could preserve the old names (also in the other patches) by simply converting
to plural form. Here it would be: smbus_eeprom_infos. OK?
Best regards,
Bernhard
>
>-corey
>
>> + {
>> + .name = TYPE_SMBUS_EEPROM,
>> + .parent = TYPE_SMBUS_DEVICE,
>> + .instance_size = sizeof(SMBusEEPROMDevice),
>> + .class_init = smbus_eeprom_class_initfn,
>> + },
>> };
>>
>> -static void smbus_eeprom_register_types(void)
>> -{
>> - type_register_static(&smbus_eeprom_info);
>> -}
>> -
>> -type_init(smbus_eeprom_register_types)
>> +DEFINE_TYPES(types)
>>
>> void smbus_eeprom_init_one(I2CBus *smbus, uint8_t address, uint8_t
>> *eeprom_buf)
>> {
>> --
>> 2.47.0
>>
>>
- Re: [PATCH v3 12/26] hw/i2c/mpc_i2c: Prefer DEFINE_TYPES() macro, (continued)
- [PATCH v3 14/26] hw/pci-host/ppce500: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
- [PATCH v3 16/26] hw/net/fsl_etsec/etsec: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
- [PATCH v3 17/26] hw/gpio/mpc8xxx: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
- [PATCH v3 20/26] hw/sd/sdhci: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
- [PATCH v3 21/26] hw/block/pflash_cfi01: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
- [PATCH v3 23/26] hw/rtc/ds1338: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
- [PATCH v3 26/26] MAINTAINERS: Add hw/gpio/gpio_pwr.c, Bernhard Beschow, 2024/11/02
- [PATCH v3 22/26] hw/i2c/smbus_eeprom: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
[PATCH v3 08/26] hw/ppc/e500: Extract ppce500_ccsr.c, Bernhard Beschow, 2024/11/02
[PATCH v3 13/26] hw/pci-host/ppce500: Reuse TYPE_PPC_E500_PCI_BRIDGE define, Bernhard Beschow, 2024/11/02
[PATCH v3 18/26] hw/ppc/mpc8544_guts: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
[PATCH v3 19/26] hw/intc: Guard openpic_kvm.c by dedicated OPENPIC_KVM Kconfig switch, Bernhard Beschow, 2024/11/02
[PATCH v3 24/26] hw/usb/hcd-ehci-sysbus: Prefer DEFINE_TYPES() macro, Bernhard Beschow, 2024/11/02
[PATCH v3 25/26] hw/vfio/platform: Let vfio_start_eventfd_injection() take VFIOPlatformDevice pointer, Bernhard Beschow, 2024/11/02