[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [v2 Patch 2/9]block: raw-posix image file reopen
From: |
Supriya Kannery |
Subject: |
Re: [Qemu-devel] [v2 Patch 2/9]block: raw-posix image file reopen |
Date: |
Tue, 14 Aug 2012 16:23:19 +0530 |
User-agent: |
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.20) Gecko/20110817 Fedora/3.1.12-1.fc14 Thunderbird/3.1.12 |
On 07/31/2012 10:47 PM, Eric Blake wrote:
> On 07/30/2012 03:34 PM, Supriya Kannery wrote:
>> + s->fd = dup3(raw_rs->stash_s->fd, s->fd, O_CLOEXEC);
>
> You called it out in your cover letter, but just pointing out that this
> is one of the locations that needs a conditional fallback to
> dup2/qemu_set_cloexec if dup3 and O_CLOEXEC are missing.
>
> More importantly, though, you want this to be fcntl(F_DUP_CLOEXEC) and
> NOT dup3, so that you are duplicating to the first available fd rather
> than accidentally overwriting whatever s->fd happened to be on entry.
> Also, where is your error checking that you didn't just assign s->fd to
> -1? It looks like your goal here is to stash a copy of the fd, so that
> on failure you can then pivot over to your copy.
>
Will use fcntl(F_DUP_CLOEXEC) in updated patch.
>> +
>> + *prs =&(raw_rs->reopen_state);
>> +
>> + /* Flags that can be set using fcntl */
>> + int fcntl_flags = BDRV_O_NOCACHE;
>
> This variable name is misleading; fcntl_flags in my mind implies O_* not
> BDRV_O_*, as we are not guaranteed that they are the same values. Maybe
> bdrv_flags is a better name. Or are you trying to list the subset of
> BDRV_O flags that can be changed via mapping to the appropriate O_ flag
> during fcntl?
>
From the list of flags in bdrv->openflags (BDRV_O*), only few of them can be
changed
using fcntl. So to identify those allowed subset, I am using fcntl_flags.
Excerpt from man fcntl for F_SETFL:
On Linux this command can only change the O_APPEND, O_ASYNC,
O_DIRECT, O_NOATIME, and O_NONBLOCK flags.
May be naming it fcntl_supported_flags would be better?
- thanks, Supriya