Am 02.06.2014 um 17:04 hat Chrysostomos Nanakos geschrieben:
Hi,
On 06/02/2014 05:30 PM, Eric Blake wrote:
On 06/02/2014 08:15 AM, Chrysostomos Nanakos wrote:
VM Image on Archipelago volume is specified like this:
file=archipelago:<volumename>[/mport=<mapperd_port>[:vport=<vlmcd_port>]]
or
I still think that there is no need to burden the code with this
shorthand...
If everyone agrees I can totally remove that part.
I don't think it's a bad idea to provide a shortcut for human users. The
important point is just that internally it's not the main interface, but
mapped to the structured option (which I think your patch achieves now).
file.driver=archipelago,file.volume=<volumename>[,file.mport=<mapperd_port>[,
file.vport=<vlmcd_port>]]
...when this version is easier to support. Older protocols have file=
abuse due to back-compat reasons, but new protocols should not start out
with baggage.
---
MAINTAINERS | 5 +
block/Makefile.objs | 1 +
block/archipelago.c | 1174 +++++++++++++++++++++++++++++++++++++++++++++++++++
This is a lot to review at once - is there any reasonable way to break
it into a series of smaller patches?
It will be really difficult to break it in smaller patches, and I
believe it will more difficult for someone to review it.
Not sure how much easier the review would become, but the obvious split
that works almost always is to do a read-only driver in patch 1, and
then add write and create support in patches 2 and 3.