[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH 0/6] virtio-blk: Unify request handling of dataplane
From: |
Fam Zheng |
Subject: |
[Qemu-devel] [PATCH 0/6] virtio-blk: Unify request handling of dataplane |
Date: |
Tue, 17 Jun 2014 11:44:55 +0800 |
This is based on top of my request converging series:
[PATCH v4 0/9] virtio-blk: Converge VirtIOBlockRequest into VirtIOBlockReq
Most of the request handlings are already the same now between dataplane and
non-dataplane, except the missing IO accounting, error reporting and
multiwrite. With this series, dataplane pulls in all of them by reusing
non-dataplane handling code.
Thread safety of error reporting relies on Paolo's series:
[PATCH 0/5] qemu-char/monitor: make monitor_puts thread safe
[PATCH v2 0/2] block: thread-safety patches for virtio-blk dataplane
rerror/werror
Fam Zheng (4):
virtio-blk: Make request completion function virtual
virtio-blk: Export request handling functions to dataplane
virtio-blk: Unify {non-,}dataplane's request handlings
virtio-blk: Rename complete_request_early to complete_request_vring
Stefan Hajnoczi (2):
block: make bdrv_query_stats() static
block: acquire AioContext in qmp_query_blockstats()
block/qapi.c | 6 +-
hw/block/dataplane/virtio-blk.c | 180 ++++------------------------------------
hw/block/virtio-blk.c | 19 +++--
include/block/qapi.h | 1 -
include/hw/virtio/virtio-blk.h | 12 +++
5 files changed, 42 insertions(+), 176 deletions(-)
--
2.0.0
- [Qemu-devel] [PATCH 0/6] virtio-blk: Unify request handling of dataplane,
Fam Zheng <=
- [Qemu-devel] [PATCH 1/6] block: make bdrv_query_stats() static, Fam Zheng, 2014/06/16
- [Qemu-devel] [PATCH 2/6] block: acquire AioContext in qmp_query_blockstats(), Fam Zheng, 2014/06/16
- [Qemu-devel] [PATCH 3/6] virtio-blk: Make request completion function virtual, Fam Zheng, 2014/06/16
- [Qemu-devel] [PATCH 4/6] virtio-blk: Export request handling functions to dataplane, Fam Zheng, 2014/06/16
- [Qemu-devel] [PATCH 5/6] virtio-blk: Unify {non-, }dataplane's request handlings, Fam Zheng, 2014/06/16
- [Qemu-devel] [PATCH 6/6] virtio-blk: Rename complete_request_early to complete_request_vring, Fam Zheng, 2014/06/16
- Re: [Qemu-devel] [PATCH 0/6] virtio-blk: Unify request handling of dataplane, Paolo Bonzini, 2014/06/17