qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v24 1/7] target/avr: Add outward facing interfac


From: Igor Mammedov
Subject: Re: [Qemu-devel] [PATCH v24 1/7] target/avr: Add outward facing interfaces and core CPU logic
Date: Tue, 2 Jul 2019 10:47:48 +0200

On Mon, 1 Jul 2019 06:59:39 -0700
Michael Rolnik <address@hidden> wrote:

> should I use *-avr-cpu* suffix or can I do without it. i.e. *xyz* instead
> of *xyz-avr-cpu*
I think our convention for cpu types is:
  foo-target-cpu
suffix. So I'd use *-avr-cpu form.
Yes it will be a bit verbose on CLI but it really doesn't matter as
there aren't any preexisting users that used short 'cpu model' form.

> 
> On Mon, Jul 1, 2019 at 2:08 AM Igor Mammedov <address@hidden> wrote:
> 
> > On Fri, 28 Jun 2019 18:54:27 +0300
> > Michael Rolnik <address@hidden> wrote:
> >  
> > > Igor.
> > >
> > > so avr6 instead of a6-avr-cpu, xmega2 instead of xmega2-avr-cpu and so  
> > on,  
> > > right?  
> > (it would be better if question was rith under context that prompted it)
> > [...]
> >  
> > > > > +++ b/target/avr/cpu.h
> > > > > @@ -0,0 +1,283 @@
> > > > > +/*
> > > > > + * QEMU AVR CPU
> > > > > + *
> > > > > + * Copyright (c) 2016 Michael Rolnik
> > > > > + *
> > > > > + * This library is free software; you can redistribute it and/or
> > > > > + * modify it under the terms of the GNU Lesser General Public
> > > > > + * License as published by the Free Software Foundation; either
> > > > > + * version 2.1 of the License, or (at your option) any later  
> > version.  
> > > > > + *
> > > > > + * This library is distributed in the hope that it will be useful,
> > > > > + * but WITHOUT ANY WARRANTY; without even the implied warranty of
> > > > > + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
> > > > > + * Lesser General Public License for more details.
> > > > > + *
> > > > > + * You should have received a copy of the GNU Lesser General Public
> > > > > + * License along with this library; if not, see
> > > > > + * <http://www.gnu.org/licenses/lgpl-2.1.html>
> > > > > + */
> > > > > +
> > > > > +#ifndef CPU_AVR_H
> > > > > +#define CPU_AVR_H
> > > > > +
> > > > > +#include "qemu-common.h"
> > > > > +#include "qom/cpu.h"
> > > > > +#include "exec/cpu-defs.h"
> > > > > +#include "fpu/softfloat.h"
> > > > > +
> > > > > +#define TCG_GUEST_DEFAULT_MO 0
> > > > > +
> > > > > +#define TYPE_AVR_CPU "avr-cpu"
> > > > > +
> > > > > +#define AVR_CPU_TYPE_SUFFIX "-" TYPE_AVR_CPU
> > > > > +#define AVR_CPU_TYPE_NAME(name) (name AVR_CPU_TYPE_SUFFIX)  
> > > > we probably can do without above macro and opencode typenames
> > > > directly since we don't have 'model' notion and don't need
> > > > translate it into typename anymore.  
> > I'd guess question was about that part.
> > What I've meant is to replace
> >  AVR_CPU_TYPE_NAME("avr6") and etc
> > with
> >  "avr6-avr-cpu"
> >    or even better with macro
> >  TYPE_AVR6_CPU "avr6-avr-cpu"
> > use it through out the code
> > and do the same for other sub-types
> >
> > [...]
> >
> >  
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]