qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v1 2/3] virtio-balloon: Better names for offset


From: David Gibson
Subject: Re: [Qemu-devel] [PATCH v1 2/3] virtio-balloon: Better names for offset variables in inflate/deflate code
Date: Mon, 22 Jul 2019 12:29:30 +1000
User-agent: Mutt/1.12.0 (2019-05-25)

On Fri, Jul 19, 2019 at 06:01:19PM +0200, David Hildenbrand wrote:
> "host_page_base" is really confusing, let's make this clearer, also
> rename the other offsets to indicate to which base they apply.
> 
> offset -> mr_offset
> ram_offset -> rb_offset
> host_page_base -> rb_aligned_offset
> 
> While at it, use QEMU_ALIGN_DOWN() instead of a handcrafted computation
> and move the computation to the place where it is needed.
> 
> Signed-off-by: David Hildenbrand <address@hidden>

Acked-by: David Gibson <address@hidden>

> ---
>  hw/virtio/virtio-balloon.c | 26 +++++++++++++-------------
>  1 file changed, 13 insertions(+), 13 deletions(-)
> 
> diff --git a/hw/virtio/virtio-balloon.c b/hw/virtio/virtio-balloon.c
> index 287d5d4c97..29cee344b2 100644
> --- a/hw/virtio/virtio-balloon.c
> +++ b/hw/virtio/virtio-balloon.c
> @@ -47,24 +47,23 @@ static void virtio_balloon_reset_pbp(VirtIOBalloon 
> *balloon)
>  }
>  
>  static void balloon_inflate_page(VirtIOBalloon *balloon,
> -                                 MemoryRegion *mr, hwaddr offset)
> +                                 MemoryRegion *mr, hwaddr mr_offset)
>  {
> -    void *addr = memory_region_get_ram_ptr(mr) + offset;
> +    void *addr = memory_region_get_ram_ptr(mr) + mr_offset;
> +    ram_addr_t rb_offset, rb_aligned_offset;
>      RAMBlock *rb;
>      size_t rb_page_size;
>      int subpages;
> -    ram_addr_t ram_offset, host_page_base;
>  
>      /* XXX is there a better way to get to the RAMBlock than via a
>       * host address? */
> -    rb = qemu_ram_block_from_host(addr, false, &ram_offset);
> +    rb = qemu_ram_block_from_host(addr, false, &rb_offset);
>      rb_page_size = qemu_ram_pagesize(rb);
> -    host_page_base = ram_offset & ~(rb_page_size - 1);
>  
>      if (rb_page_size == BALLOON_PAGE_SIZE) {
>          /* Easy case */
>  
> -        ram_block_discard_range(rb, ram_offset, rb_page_size);
> +        ram_block_discard_range(rb, rb_offset, rb_page_size);
>          /* We ignore errors from ram_block_discard_range(), because it
>           * has already reported them, and failing to discard a balloon
>           * page is not fatal */
> @@ -80,11 +79,12 @@ static void balloon_inflate_page(VirtIOBalloon *balloon,
>      warn_report_once(
>  "Balloon used with backing page size > 4kiB, this may not be reliable");
>  
> +    rb_aligned_offset = QEMU_ALIGN_DOWN(rb_offset, rb_page_size);
>      subpages = rb_page_size / BALLOON_PAGE_SIZE;
>  
>      if (balloon->pbp
>          && (rb != balloon->pbp->rb
> -            || host_page_base != balloon->pbp->base)) {
> +            || rb_aligned_offset != balloon->pbp->base)) {
>          /* We've partially ballooned part of a host page, but now
>           * we're trying to balloon part of a different one.  Too hard,
>           * give up on the old partial page */
> @@ -96,10 +96,10 @@ static void balloon_inflate_page(VirtIOBalloon *balloon,
>          size_t bitlen = BITS_TO_LONGS(subpages) * sizeof(unsigned long);
>          balloon->pbp = g_malloc0(sizeof(PartiallyBalloonedPage) + bitlen);
>          balloon->pbp->rb = rb;
> -        balloon->pbp->base = host_page_base;
> +        balloon->pbp->base = rb_aligned_offset;
>      }
>  
> -    set_bit((ram_offset - balloon->pbp->base) / BALLOON_PAGE_SIZE,
> +    set_bit((rb_offset - balloon->pbp->base) / BALLOON_PAGE_SIZE,
>              balloon->pbp->bitmap);
>  
>      if (bitmap_full(balloon->pbp->bitmap, subpages)) {
> @@ -116,18 +116,18 @@ static void balloon_inflate_page(VirtIOBalloon *balloon,
>  }
>  
>  static void balloon_deflate_page(VirtIOBalloon *balloon,
> -                                 MemoryRegion *mr, hwaddr offset)
> +                                 MemoryRegion *mr, hwaddr mr_offset)
>  {
> -    void *addr = memory_region_get_ram_ptr(mr) + offset;
> +    void *addr = memory_region_get_ram_ptr(mr) + mr_offset;
> +    ram_addr_t rb_offset;
>      RAMBlock *rb;
>      size_t rb_page_size;
> -    ram_addr_t ram_offset;
>      void *host_addr;
>      int ret;
>  
>      /* XXX is there a better way to get to the RAMBlock than via a
>       * host address? */
> -    rb = qemu_ram_block_from_host(addr, false, &ram_offset);
> +    rb = qemu_ram_block_from_host(addr, false, &rb_offset);
>      rb_page_size = qemu_ram_pagesize(rb);
>  
>      if (balloon->pbp) {

-- 
David Gibson                    | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au  | minimalist, thank you.  NOT _the_ _other_
                                | _way_ _around_!
http://www.ozlabs.org/~dgibson

Attachment: signature.asc
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]